Hi all,

I'm trying to get the worldcookery example egg to run inside a
zopeproject buildout.

But now I'm stuck with the following traceback:

    ZopeXMLConfigurationError: File
"/home/gyst/z3_book/eggs/worldcookery-2.0.1-py2.4.egg/worldcookery/skin/configure.zcml",
line 56.2
    ConfigurationError: ('Unknown directive',
u'http://namespaces.zope.org/browser', u'viewletManager')

I'm aware that the book is written against Zope 3.3 and my buildout runs
3.4. However, I definitely want to get Zope3 running using buildout
since that is our preferred way of doing dependency-isolated, repeatable
development and deployment nowadays.

I've added some extra dependencies to setup.py:

                        ## The following are needed for worldcookery
                        'worldcookery',
                        'zope.viewlet',

And included those packages in site.zcml

  <!-- worldcookery *after* zope.app.securitypolicy
       and other dependencies-->
  <include package="zope.viewlet" />
  <include package="worldcookery" />


I've tried installing z3c.viewlet but that doesn't help. Also,
zope.viewlet.manager is present in the zope.viewlet egg.

How do I go from here?

:*CU#
-- 
***   Guido A.J. Stevens           ***  mailto:[EMAIL PROTECTED]   ***
***   NFG Net Facilities Group BV  ***  tel: +31.43.3618933   ***
***   Postbus 1143                 ***  fax: +31.43.3561655   ***
***   6201 BC  Maastricht          ***  http://www.nfg.nl     ***
_______________________________________________
Zope3-users mailing list
Zope3-users@zope.org
http://mail.zope.org/mailman/listinfo/zope3-users

Reply via email to