On Wed, 7 Jun 2000, Dieter Maurer wrote:

> Bryan Stillwell writes:
>  > Here's the traceback I received:
>  > 
>  >   Sorry, a Zope error occurred.<p>
>  > <!--
>  > Traceback (innermost last):
>  >   File /usr/share/zope/lib/python/Products/WorldPilot/WorldPilot.py, line 1878, 
>in getpart
>  >     (Object: RoleManager)
>  >   File /usr/share/zope/lib/python/Products/WorldPilot/WorldPilot.py, line 856, in 
>  >   File /var/tmp/python/python-root/usr/lib/python1.5/mimetools.py, line 146, in 
>  > ValueError: unknown Content-Transfer-Encoding: 8bit
> "mimetools.encode/decode" do not handle transfer encodings "7bit", "8bit"
> and "binary", because there is nothing to do for them.
> "WordPilot" should check for them and not call "decode".

Yeah, I finally got to RTFS and found a bug in their code.  I was able to
fix my problem by changing these two lines in WorldPilot.py:


To these:


I found out after adding some debug info to the code that it was
comparing BodyType to see if it was set to 'TEXT', but when it was doing
the comparison it was actually set to 'text', so it would fail.  I didn't
bother finding out why 'text' was in all lower case...

>  > Another strange thing is the path to the mimetools.py file in the
>  > traceback: /var/tmp/python/python-root/usr/lib/python1.5/.  The
>  > /var/tmp/python/python-root path should have only been used during the
>  > creation of the python rpm, but it's showing up now.
> The "*.pyc" files remember the name they have been compiled from.

Makes sense...

Thanks for the help!  I'm going to send a patch to the WorldPilot people
to see if they'll fix it before the next release.

Have a great day!


Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to