Be careful here ... I think you'll also find that should you try to download
the attachement, It'll kill Zope. If you're running Zope with -D it'll
restart, otherwise you'll find you have no web site after trying to
download. I'm not sure what it does to kill Zope as there is no error, just
death. It seems to be a bit intermittent as well, which doesn't help.

I'm trying to fix the problem and will post the patch once it's ready,
hopefully next week when I get back from China. (I'm nothing to do with the
WorldPilot chaps, I just want to use the s/ware)


                  From: Dieter Maurer  <[EMAIL PROTECTED]>
                  Date: Wed Jun 7, 2000 9:03pm
                  Subject: Re: [Zope] WorldPilot - Regular messages are

                  Bryan Stillwell writes:

                  > Here's the traceback I received:
                  >   Sorry, a Zope error occurred.<p>
                  > <!--
                  > Traceback (innermost last):
                  >   File
/usr/share/zope/lib/python/Products/WorldPilot/, line 1878, in
                  >     (Object: RoleManager)
                  >   File
/usr/share/zope/lib/python/Products/WorldPilot/, line 856, in
                  >   File
/var/tmp/python/python-root/usr/lib/python1.5/, line 146, in
                  > ValueError: unknown Content-Transfer-Encoding: 8bit
"mimetools.encode/decode" do not handle transfer encodings "7bit", "8bit"
                  "binary", because there is nothing to do for them.

                  "WordPilot" should check for them and not call "decode".

                  > Another strange thing is the path to the
file in the
                  > traceback:
/var/tmp/python/python-root/usr/lib/python1.5/.  The
                  > /var/tmp/python/python-root path should have only been
used during the
                  > creation of the python rpm, but it's showing up now. The
"*.pyc" files remember the name they have been compiled from.



Reply via email to