I am a new Zope user and am attempting to access field names of a ZSQL method.  I have 
read and tried to use the How-To : "Access the field names and fields of any arbitrary 
ZQSL query" by teyc. The code suggested there has not worked. 

For example, when I use the code:

<dtml-in SQL.names>
  <dtml-let vname=sequence-item
    <dtml-var vname>,
   <dtml-var vvalue><br>

I get the error:
Error Type: KeyError
             Error Value: SQL.names

I have nested the above code  in code that references a ZSQL method, as well as trying 
several other permutations, but nothing has worked. I'm wondering if this is a name 
lookup problem.

In checking this news group I see that several others have had similar problems.  See: 


Can anyone tell me (us)  how to correctly do this, or what mistake I (we) am making.

Version information:

Zope version: Zope 2.1.6 (binary release, python 1.5.2, win32-x86) 
    Python version: 1.5.2 (#0, Jul 30 1999, 09:52:18) [MSC 32 bit (Intel)] 


David H. Jones
Boeing Phantom Works,
Mathematics and Computing Technology
425-865-2964 (FAX)

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to