Hmm..., so I've decided to upgrade to Zope 2.2.0. Most of my site works
fine :)

I used GUF lately, now I want to use LoginManager, but I can't get it
working.

Even on fresh install of Zope 2.2.0 (Linux x86, binary release of Zope),
when I want to create an instance of Login Manager with default settings 
in folder 'test1', I get following error:

Error Type: TypeError
Error Value: keyword parameter redefined

Traceback (innermost last):
  File /usr/local/digicool/Zope-2.2.0-linux2-x86/lib/python/ZPublisher/
     Publish.py, line 222, in publish_module
  File /usr/local/digicool/Zope-2.2.0-linux2-x86/lib/python/ZPublisher/
     Publish.py, line 187, in publish
  File /usr/local/digicool/Zope-2.2.0-linux2-x86/lib/python/Zope/
     __init__.py, line 221, in zpublisher_exception_hook
  File /usr/local/digicool/Zope-2.2.0-linux2-x86/lib/python/ZPublisher/
     Publish.py, line 171, in publish
  File /usr/local/digicool/Zope-2.2.0-linux2-x86/lib/python/ZPublisher/
     mapply.py, line 160, in mapply
    (Object: manage_addLoginManager)
  File /usr/local/digicool/Zope-2.2.0-linux2-x86/lib/python/ZPublisher/
     Publish.py, line 112, in call_object
    (Object: manage_addLoginManager)
  File /usr/local/digicool/Zope-2.2.0-linux2-x86/lib/python/Products/
     LoginManager/LoginManager.py, line 237, in manage_addLoginManager
  File /usr/local/digicool/Zope-2.2.0-linux2-x86/lib/python/Products/
     ZPatterns/PlugIns.py, line 313, in _constructPlugIn
TypeError: (see above)


I've tried installing ZPatterns from sources and from binary release (both
0.3.0) - same results. LoginManager - 0.8.6.

Of course I've created user with manager role in root folder's acl_users
folder.

What's wrong, Zopistas ?


ololo


_______________________________________________
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to