Hi all,
This is of interest to those people using the (excellent) PDF generator,

ReportLab <http://www.reportlab.com/> under Zope. 

As you may know, there is an import conflict with the 'Image' module from PIL

and the built in Zope 'Image' module when using ReportLab. The snippet below

is from the main ReportLab developer, Andy Robinson.

> If it's not too much trouble, that would be very useful for 
> those of 
> us using Zope (the number is growing all the time).

We will try to do this.  But which import format 
does Zope require? 'import Image'
of 'import PIL.Image'?  And is this some sort of
packaged 'PIL-for-Zope'?  If it was just PIL on your
hard disk, you would have 100% control over the
problem just by adding the right directory to your

Sorry, I'm working all hours and don't have time to
download and play with Zope this month.

- Andy


So, can anyone with a higher 'import' Zope Zen please give me a clue as to how

to reply to Andy? In my own reportlab distribution I changed;
import Image
from PIL import Image
and that seemed ok, but I'd like a 'definitive' answer on this from some bods

with Nirvana-level Zen....

BTW, If you're not a reportlab user (open source, free download), then you're

missing out - this is terrific software...we have it connected to ZSQL methods

and are churning out PDF documents *very* quickly.


Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to