I just want to resume a thread from september. Has anyone else
encountered problems installing Zope (in our case 2.2.2) under Solaris
8? And more important: Do you know a solution?
Python is unable to import the ExtensionClass. I tried it from
(python 1.5.2 (#1, Oct 19 2000, 13:55:34)  [GCC 2.95.3 19991030
(prerelease)] on sunos5)
also and got the same Import Error:

--------------- command and traceback following
[~/Zope-2.2.2] ./start

Traceback (innermost last):
File "/...../Zope-2.2.2/z2.py", line 554, in exec "import "+MODULE in {}
File "<string>", line 1, in File
"/...../Zope-2.2.2/lib/python/Zope/__init__.py", line
94, in import ZODB, ZODB.ZApplication, imp
File "/...../Zope-2.2.2/lib/python/ZODB/__init__.py", line 85, in 
import sys, ExtensionClass, TimeStamp, cPersistence, Persistence
ImportError: ld.so.1: /usr/local/bin/python: fatal: relocation error:
file /mnt/disk2/homes/wklinik/Zope-2.2.2/lib/python/ExtensionClass.so:
symbol PyImport_ImportModule: referenced symbol not found

  Thies Bähr.

 Jan-Thies Bähr                          
 Intelligent Visualization & Simulation
 DFKI GmbH                                Email: [EMAIL PROTECTED]
 D-67608 Kaiserslautern (Germany)         Phone: +49 (0) 631 205-4565

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to