I think you should do "Find Items to ZCatalog" and do a clean index of the
whole website. Apparently "Update Catalog" doesn't touch the old invalid
pointers in the index.

Also, for Yihaw you must find object of all types otherwise it won't catalog
the subclassed objects!

The correct behaviour in 2.2 is with a preceeding '/'.

|| -----Original Message-----
|| From: Didier Georgieff [mailto:[EMAIL PROTECTED]]
|| Sent: Friday, December 08, 2000 10:45
|| To: [EMAIL PROTECTED]
|| Cc: [EMAIL PROTECTED]
|| Subject: Strange Catalog problem.
|| 
|| 
|| Hello,
|| 
|| I'm using a modified (french, adding programatically and new 
|| classes but 
|| the ground features are untouched) Yihaw on 2.2.4 (linux).
|| 
|| I've got a strange behaviours (YihawNews boxes don't show 
|| the new items) 
|| until i found that "old" (before upgrading to 2.2.2 + 2.2.4 
|| update) items on 
|| the catalog don't start with "/" and the new ones does start 
|| with "/".
|| 
|| Reindexing gives me the same 2 categories and change nothing.
|| 
|| I'm puzzled with :
|| * what is the "correct behaviour / or no / ?
|| * why reindexing doesn't homogenize the / ?
|| 
|| The "new" items are now added programatically and the "old" 
|| ones where 
|| done thru Zope interface.
|| 
|| And sometimes i still get a "problem uncataloging before 
|| catalogging" 
|| message on the Zope console.
|| 
|| Am i missing some important change ?
|| Thanks in advance.
|| 
|| 
|| --
|| Didier Georgieff
|| DDAF du Bas-Rhin - Cellule SIG 
|| 2, rue des Mineurs 67070 Strasbourg Cedex
|| tél : 03.88.25.20.33 - fax : 03.88.25.20.01
|| email : [EMAIL PROTECTED]
|| SIT du Bas-Rhin : http://www.bas-rhin.sit.gouv.fr
|| GéoWeb http://sertit10.u-strasbg.fr
|| 

_______________________________________________
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to