Hi Angie.

First off, I think there are some users in the list that are unable to read
HTML formatted email.  I've seen a lot of requests for folks to send only
plain text messages to the list.

Well, I don't run Zope on a Windows machine, so maybe I'm wrong here, but
the output you've shown below looks normal to me.  It doesn't look like an
error.  Is there any error message that's displayed in your browser?  If so,
can you recreate it and send it to the list?

Also, can you include the SQL statement that is causing the problem?  Have
you tried making a ZSQL Method that issues a really simple query, like:
SELECT * FROM InsertYourTableNameHere

You can also try this simple test from your "Z MySQL Database Connection"
object.  Just browse to that object in the Zope management interface, click
the "Test" tab and then enter the SQL statement.  Then click the "Submit
Query" button to test it.  It should return all the records in the table you
specified.  If it doesn't, I would hope it simply returns a traceback and
not crash Zope.

Hope that helps.


-----Original Message-----
From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]]On Behalf Of Angietel
Sent: Wednesday, December 13, 2000 12:42 AM
Subject: [Zope] Problem on running the ZOPE by using ZmySQLDA

Finally my ZOPE is connected to MySQL succesfully, i can insert, delete the
record,but i can not search and view my record in ZOPE. When i go to MySQL
it can shows all my database records after my modification in ZOPE. Every
time when i want to search or view my records it will promt out the illegal
operation message in ZOPE and my pyhon will be exactly look like this:-

iles\WebSite\z2.py" -D
2000-12-13T08:34:28 PROBLEM(100) ZServer Computing default hostname
2000-12-13T08:34:31 INFO(0) ZServer Medusa (V1.16.4.2) started at Wed Dec 13
34:31 2000
        Hostname: ANGIE

2000-12-13T08:34:31 INFO(0) ZServer FTP server started at Wed Dec 13
16:34:31 20
        Hostname: angie
        Port: 8021
2000-12-13T08:34:31 INFO(0) ZServer PCGI Server started at Wed Dec 13
16:34:31 2
        Inet socket port: 8090
2000-12-13T08:34:31 INFO(0) ZServer Monitor Server (V1.8) started on port

C:\Program Files\WebSite>

P/s let me know me that whether this is regard to my MySQL or ZOPE or
Python, but i have tried to reinstall all of them, and the situation is
still remain the same. Thanks for your concern.

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to