Hi listies,

On a client's server I created a ZCatalog, but when using "Find Items to 
ZCatalog" and clicking on "Find" in the form, Zope raises the "list index 
out of range" error shown in detail at the end of this e-mail. Then I took 
the whole Data.fs, put it on one of our servers, where everything worked as 

Since our client wants to create various ZCatalogs, he has to use this 
functionality :-/

Any ideas where to start looking for the reason of this error?

Our client's server's configuration is the following:
Zope version: Zope 2.2.4 (source release, python 1.5.2, linux2) [ I have 
also tried with 2.2.2 source]
Python version: 1.5.2 (#1, Aug 25 2000, 09:33:37) [GCC 2.96 20000731 
System Platform: linux-i386 [RedHat 7.0]

Any help is greatly appreciated!

Here is the output when I submit the form "Find Items to ZCatalog":

Error Type: IndexError
Error Value: list index out of range

Traceback (innermost last):
   File /usr/local/Zope-2.2.4-src/lib/python/ZPublisher/Publish.py, line 
222, in publish_module
   File /usr/local/Zope-2.2.4-src/lib/python/ZPublisher/Publish.py, line 
187, in publish
   File /usr/local/Zope-2.2.4-src/lib/python/Zope/__init__.py, line 221, in 
     (Object: Traversable)
   File /usr/local/Zope-2.2.4-src/lib/python/ZPublisher/Publish.py, line 
171, in publish
   File /usr/local/Zope-2.2.4-src/lib/python/ZPublisher/mapply.py, line 
160, in mapply
     (Object: manage_catalogFoundItems)
   File /usr/local/Zope-2.2.4-src/lib/python/ZPublisher/Publish.py, line 
112, in call_object
     (Object: manage_catalogFoundItems)
   File /usr/local/Zope-2.2.4-src/lib/python/Products/ZCatalog/ZCatalog.py, 
line 321, in manage_catalogFoundItems
     (Object: Traversable)
IndexError: (see above)

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to