Well, I figured out a kludge from the "How to backup Zope data base?" thread
and from the rc shutdown script. Turns out I needed to remove the Data.fs.*,
pcgi.soc, and *.pid files -- leaving ONLY Data.fs and a few others, like the
FSSession directory.

That got both 2.2.5 and 2.3b1 to start up with my data. Only problem is that
all instances of the ZClass I had created in my product (which I named
ArticleProduct, btw) are broken in 2.3b1. The product itself appears in the
Product Management menu, but even instances of ZClasses within the product
are broken. Re-importing ArticleProduct.zexp does no good... I still get
that "append" AttributeError (see traceback below). Is this a bug w/ 2.3b1
or am I missing something?

Any help?

> I'm trying to upgrade to 2.3.0b1 from 2.2.5b1... I installed the new version
> (according to the ZopeInstall HowTo, just to be safe), which started fine. I
> then shutdown Zope (2.3.0b1), moved the default var/Data.fs* files to a
> backup directory, then copied my old Data.fs* files over. When I tried to
> re-start 2.3.0b1, nothing happened. No debug message either. So I put the
> default Data.fs* files back in and restarted successfully.
> Fine, I thought, the database files aren't all that necessary. All the work
> I'd done on the previous version had been exported to a .zexp product export
> file, which were all subclassed from your run-of-the-mill ZClasses (image,
> file, folder, object manager, ZCatalog aware) and used DTML for all methods.
> No PythonMethods, no FSSessions, etc. So I put the .zexp file into the
> "import" folder and tried to import the product from within Zope. I got this
> error:
> Error Type: AttributeError
> Error Value: append
> Traceback (innermost last):
> File /usr/local/zope/2-3/lib/python/ZPublisher/Publish.py, line 222, in
> publish_module
> File /usr/local/zope/2-3/lib/python/ZPublisher/Publish.py, line 187, in
> publish
> File /usr/local/zope/2-3/lib/python/Zope/__init__.py, line 221, in
> zpublisher_exception_hook
> (Object: Traversable)
> File /usr/local/zope/2-3/lib/python/ZPublisher/Publish.py, line 171, in
> publish
> File /usr/local/zope/2-3/lib/python/ZPublisher/mapply.py, line 160, in
> mapply
> (Object: manage_importObject)
> File /usr/local/zope/2-3/lib/python/ZPublisher/Publish.py, line 112, in
> call_object
> (Object: manage_importObject)
> File /usr/local/zope/2-3/lib/python/OFS/ObjectManager.py, line 542, in
> manage_importObject
> (Object: Traversable)
> File /usr/local/zope/2-3/lib/python/ZODB/ExportImport.py, line 208, in
> importFile
> AttributeError: (see above)
> Here's my questions:
> 1. Why are my old data files screwing up Zope 2.3.0b1?
> 2. Why can't I import my product?
> Note: I also tried this with 2.2.5b1 --> 2.2.5, same errors.
> Any insights? Thanks,
> ajl

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to