Hi Brian,

Brian Hickey wrote:

Unfortunately, python doesn't seem to have been installed from ports (at
least, not directly).  The environment I'm working on is a shared host
implementing a virtual private server.  To install python (and other tools),
I have to use some kind of packager tool called vinstall.  Unfortunately,
this gives me no config options, except which version of python I wish to

i have my own freebsd servers (atm updating from 5.3-Stable to 5.4-Release), so i can use the ports directly.

can you compile your own python?
(remember to compile with the flag "-DTHREAD_STACK_SIZE=0x100000" set, this is what the option HUGE_STACK_SIZE does, also don't forget to configure --with-threads)

Don't know about the other patches/flags.

I have sent a request to the hosts' support to get the Makefile.pre.in file, so I can determine what stack size they have set for the vinstall.

don't know if it is visible there.

I have been at this for several evenings now (can't do it during normal
working hours in case I break the server [yeah, it's nice to have the
confidence of superiors!]), and bit the bullet today, and tried to reinstall
the latest of everything.  I now have Zope 2.7.4 using Python 2.3.4.  I can
add all the various products in the Plone 2.0.5 tarball it all works, with
the exception of CMFPlone.  Once this directory is added, Zope refuses to
respond.  So, I'm still no closer to even identifying where the problem
actually is, but my suspicion is still python.

this is exactly the symptom when the stack size is not upped, so i think it is really this problem.

So much for the new Plone website tomorrow afternoon :)

Ciao, Jochen -- -------------------------------------------------- Jochen Knuth WebMaster http://www.ipro.de IPRO GmbH Phone ++49-7152-93330 Steinbeisstr. 6 Fax ++49-7152-933340 71229 Leonberg EMail: [EMAIL PROTECTED]

Zope maillist - Zope@zope.org
** No cross posts or HTML encoding! **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to