Thanks, Shane. That fixes the problem of Zope not starting, and better than the other syntax I tried, but it still doesn't fix the core problem. My root Ape installs have issues with adding a local role, as then the default roles get axed. If you add this fix then Zope re-adds Owner (and Authenticated, as you need to duplicate the fix a couple lines lower) during the start-up, but not Manager - and they are not really added, but sort of hacked in by the start-up code. Shouldn't Ape be somehow dealing with this exact situation anyways, or is there just something wrong with my installs?

Thanks again for the help,
Tim


Shane Hathaway wrote:

Tim Connor wrote:
* Since the traceback isn't in this set of replies, heres the pertinent
code:
File "/usr/lib/zope-2.7.2/lib/python/OFS/Application.py", line 457, in
install_required_roles
  app.__ac_roles__=app.__ac_roles__ + ('Owner',)
TypeError: can only concatenate list (not "tuple") to list

I think a quick fix is to make the above line read:

   app.__ac_roles__ = tuple(app.__ac_roles__) + ('Owner',)

To really fix this, Ape needs to be more careful to set __ac_roles__ as
tuples.

Shane


_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to