Peter Bengtsson <[EMAIL PROTECTED]> wrote in
news:[EMAIL PROTECTED]: 

> <thinking loud>
> zlib? Did your zope work fine before? 
> Remember, about 2 weeks ago they found a vunorability in zlib, didn't
> they. Maybe there are some implications into that on openbsd.
> </thinking loud>


Well, --- it doesn't sound likely, because it's not only with zlib. I 
just got this one:


2005-07-21T12:34:18 ERROR(200) SiteError 
http://nanotek.nano.ku.dk/computere/problemer/terror
Traceback (most recent call last):
  File "/usr/local/lib/zope/lib/python/ZPublisher/Publish.py", line 92, 
in publish

  File "/usr/local/lib/zope/lib/python/ZPublisher/BaseRequest.py", line 
350, in traverse
    got=1
  File "/usr/local/lib/zope/lib/python/ZODB/Connection.py", line 600, in
setstate
    # end of a transaction and if the object was invalidated
  File "/usr/local/lib/zope/lib/python/ZODB/Connection.py", line 639, in
_set_ghost_state

  File "/usr/local/lib/zope/lib/python/ZODB/Connection.py", line 227, in
_persistent_load
    self._cache.incrgc()
MemoryError

I restart Zope and all is well. I'm running Zope 2.7.6-final by the way.
Perhaps I should upgrade to 2.7.7. Hopefully this is solved with 2.8.0, 
but it looks like the next compatible Plone release is some way ahead 
still.

\mb

_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to