> -----Original Message-----
> Jens Vagelpohl
> Sent: 8. syyskuuta 2005 10:56
> To: Zope
> Subject: Re: [Zope] Can't get ZEO running with zeoctl start

> Have you checked all file permissions to ensure that the user running
> Zope can use them? My guess would be that you broke permissions by
> running as root, which simply is not a good thing to do. Run Zope
> under a normal user account, and change file ownership to that user.
> Then don't put zeoctl into init.d, write a small wrapper around it
> that uses zeoctl.

Hi and thanks for the help,

User zope can run "zeoctl fg" just fine, so I thought the permissions
should be OK. I have them set according to this tutorial:

Thanks for the zopectl-wrapper script, it's a lot cleaner than the one
I had made. :) I adapted it to zeoctl but the problem still remains,
zeoctl start still doesn't work.

BTW, I tried the zeo/bin/runzeo script and it works OK too.

Is it still possible it would be a file permission thing, even if zeoctl fg
and runzeo work?

Mikko Koivunen

Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to