First, I would recommend against changing anything in any file at this point except configuration files.

Next, verify that the correct python version is being used.  It's easy to have two pythons side-by-side on the same linux system.  If you built Zope from source, you (probably) should build python from source as well.  However, if you used an installable package for Zope, I would recommend staying with whatever version pairing of Zope/Python that your Linux distribution has by default.  It's simpler that way, and will probably solve your problem.  I know that I've built Zope before where it's pointed at the wrong python version, and got things all screwed up for me.  Use "`which python` -V" (those are backtics) to figure out the version that your $PATH points to by default.

If you *are* building from source, verify that you used --with-python="/path/to/python2.3.5" when you ran the configure script for Zope.  The configure script should(?) tell you if there's a problem with any module dependencies.  Again, if building Zope from source, it's probably best that you use a python built from source as well.

Good Luck!

On 12/14/05, Qass <[EMAIL PROTECTED]> wrote:

I'm new to zope and yesterday installed zope 2.8.4 on a linux system
running python 2.3.5
Having followed installation instructions I got to the point of
'zopectl start' and got the following error message while trying both
'runzope' and 'zopectl'.

I've tried installing different versions of Zope and get the same
error (error absent with Zope 3). At one point, Zope did start (I
moved it to a different port) but when I tried installing Plone in the
Products directory of the zope instance, the 'Plone Site' did not show
up in the drop down menu on the right hand side of the ZMI. Which is
why I decided to reinstall and have been getting errors since. I
haven't messed around with the Python installation at all.

In this latest install I ran 'make instance' intead of 'make install'
just to see if I would get the same error as I did yesterday when I
had an instance of Zope running and I did.

Any help in trying to fix this would be highly appreciated. I've tried
changing PYTHONPATH in the zopectl file but that just leads to more
and more errors.

Traceback (most recent call last):
  File "/blah//Zope-2.8.4-final/lib/python/Zope2/Startup/", line 56, in ?
  File "/blah/Zope-2.8.4-final/lib/python/Zope2/Startup/", line 17, in run
    import Zope2.Startup
  File "/blah/Zope-2.8.4-final/lib/python/Zope2/", line 60, in ?
    from import configure
  File "/network/share/home/sra/Zope-2.8.4-final/lib/python/Zope2/Startup/",
line 24, in ?
    import ZConfig
  File "/blah/Zope-2.8.4-final /lib/python/ZConfig/", line 21, in ?
    from ZConfig.loader import loadConfig, loadConfigFile
  File "/blah/Zope-2.8.4-final/lib/python/ZConfig/", line 23, in ?
    import ZConfig.datatypes
  File "/blah/Zope-2.8.4-final/lib/python/ZConfig/", line 19, in ?
    import datetime
  File "/blah/Zope-2.8.4-final/lib/python/DateTime/", line 13, in ?
    from DateTime import DateTime
  File "/blah/Zope-2.8.4-final/lib/python/DateTime/", line 21, in ?
    from datetime import datetime
  File "/blah/Zope-2.8.4-final/lib/python/DateTime/", line 21, in ?
    from datetime import datetime
ImportError: cannot import name datetime

Thank you very much for your help.

Zope maillist  -
**   No cross posts or HTML encoding!  **
(Related lists - )

Floyd May
Senior Systems Analyst
CTLN - CareerTech Learning Network
Zope maillist  -
**   No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to