I would like to know if anyone has been able to compile and run Zope
2.8.4 with Cygwin.

I just installed cygwin with latest stable packages.

I compiled python 2.4.2 (I know, not the supported version, so I am
about to try 2.3.5 now)
I had issues with the socket module, and from google I applied a
workaround that worked fine :
in Modules/socketmodule.c
Change :
#if defined(__sgi) && !defined(INET_ADDRSTRLEN)
To :
/*#if defined(__sgi) && !defined(INET_ADDRSTRLEN)*/

I made several python tests and all looks fine.

Then I compiled Zope 2.8.4 without any issue.

But when I run it, I get this error:

Site Error
An error was encountered while publishing this resource. 


Sorry, a site error occurred.

Traceback (innermost last): 

Module ZPublisher.Publish, line 187, in publish_module_standard 
Module Products.Localizer, line 58, in new_publish 
Module ZPublisher.Publish, line 144, in publish 
Module Zope2.App.startup, line 174, in zpublisher_exception_hook 
Module App.ZApplication, line 60, in __bobo_traverse__ 
Module UserDict, line 17, in __getitem__ 
Module ZODB.Connection, line 704, in setstate 
Module ZODB.Connection, line 760, in _setstate 
Module ZODB.serialize, line 495, in setGhostState 
Module ZODB.serialize, line 488, in getState 
Module ZODB.serialize, line 436, in _persistent_load 
Module ZODB.Connection, line 208, in get 
Module ZODB.serialize, line 482, in getGhost 
TypeError: Acquirer.__new__(Application) is not safe, use

Does anyone know what I can do ?

Thanks a lot.


This email and any files transmitted with it are confidential and
intended solely for the use of the individual or entity to whom they
are addressed. If you have received this email in error please notify
the system manager.

This footnote also confirms that this email message has been swept by
MIMEsweeper for the presence of computer viruses.


Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists -
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to