On Saturday 08 April 2006 01.24, Jonathan wrote:
> Have you tried running it as a spawned job from the shell?  If something is
> pooched in the environment then the job should hang (then you know it is
> not a zope problem).
>
> Jonathan
>

Using the "if __name__ == '__main__': main()"
I have executed the command from the External script file
(as user root) with "python aw4.py ecmd2" and it works...

But when called from zope it hangs...

I've tried with popen(...)
and spawnv(...)

I've had the script dump the environment variables
and the version dumped by root, differs from the version 
dumped from zope only in variables with "cookie" in them!

Now I tried to do a simple "cat " and it don't seam to work either...

I'm quite fustrated so it's time to go have fun (install SUSE 10 XEN on SUSE 
10....   Whoooopeeee!).

If anyone, anywhere has any ideas WTF is going on here,
please give me a hint!


Jerry




_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to