Don't know if this will help, but here is a line from one of my external methods that works:

       rstat = commands.getstatusoutput('./qrcode '+quoted_instr)

'qrcode' is a bash script file (linux) that resides in '/apps/zope/var' (no messing around with PATH or environment variables) and takes a string 'quoted_instr' as an input parameter.

if you do 'return str(rstat)' after the call you should get some error info if the call fails.



----- Original Message ----- From: "Jerry Westrick" <[EMAIL PROTECTED]>
To: <>
Sent: Saturday, April 08, 2006 10:47 AM
Subject: Re: [Zope] Problems Executing pdftk from within zope.

On Saturday 08 April 2006 01.24, Jonathan wrote:
Have you tried running it as a spawned job from the shell? If something is
pooched in the environment then the job should hang (then you know it is
not a zope problem).


Using the "if __name__ == '__main__': main()"
I have executed the command from the External script file
(as user root) with "python ecmd2" and it works...

But when called from zope it hangs...

I've tried with popen(...)
and spawnv(...)

I've had the script dump the environment variables
and the version dumped by root, differs from the version
dumped from zope only in variables with "cookie" in them!

Now I tried to do a simple "cat " and it don't seam to work either...

I'm quite fustrated so it's time to go have fun (install SUSE 10 XEN on SUSE
10....   Whoooopeeee!).

If anyone, anywhere has any ideas WTF is going on here,
please give me a hint!


Zope maillist  -
**   No cross posts or HTML encoding!  **
(Related lists - )

Zope maillist  -
**   No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to