----- Original Message ----- From: "Dieter Maurer" <[EMAIL PROTECTED]>
To: "Jonathan" <[EMAIL PROTECTED]>
Cc: <zope@zope.org>; <zodb-dev@zope.org>
Sent: Monday, August 21, 2006 2:53 PM
Subject: Re: [Problem report] "pack" discards reachable object (was: [Zope] Pack problem with zeo)

Jonathan wrote at 2006-8-21 14:05 -0400:
And the ZeoServer1 folder is back.  I then pack zope and the ZeoServer1
folder disappears again.  I can do this again and again and again.

If your "Data.fs.old" is not too large (not larger than 1 MB)
and on the path to the "ZeoServer1" are only standard Zope objects, you
could send it to me for investigation ([bg]zip it, to make it smaller).

Thanks for the very kind offer but the Data.fs file is 53Mb before packing
and 7.8Mb after packing. I tried tar/gzip but the 53Mb only dropped down to

Then you may try the following:

 Manually add the mount point after packing.
 Pack again and see whether the mount point will still vanish.
 If it does, gzip and sent it to me (privately).

Using the work-around I mentioned earlier (delete the ZeoServer1 folder, pack > 1 day, after pack undo ZeoServer1 deletion) seems to have resolved the issue. I tried packing the Data.fs again and the ZeoServer1 folder did not disappear this time!

The only thing I can think of this that there must have been some entry in the original Data.fs file that was causing the problem, and the pack removed that problem entry, but everything 'appears' to be ok now.

Thanks again for all the help!


Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to