Is anybody out there reading this list? Third question today, no responses, and 
boy am I in trouble. I went to backup my server's working HD on my new .5 
teraflop HD and for some reason that wiped out the /var dirs in my Zope 
instances. I have backups of the Data.fs that aren't too old, but for some 
reason I can't get a working copy of Zope installed! I follow the tar, 
configure, make, make install, make instance without throwing anything special 
at the configure, then I edit zope.conf to enter the correct effective-user, 
but when I go to runzope, it throws a cPersistence error. Well, I yahoo'd that 
and found out I had to run "python setup.py build_ext -if" to knock it out. But 
why should I have to do that at all? That's not standard procedure. Anyway, I 
got past that point, but now when I try runzope I get the error that follows. 
And I've tried every way I can think of to get around it. All the permissions 
are correct. Once I actually got to the point where it said Zope
 was ready to serve, could surf to the 111.222.333.444:8080 page, but try to 
get into the "manage" page and it won't accept my username/password. I ran 
zpasswd.py and still couldn't get in! Guys, I'm exhausted. I've been at this 
for 10 hours! Any help would really be appreciated.

[EMAIL PROTECTED]:local/www/clients (103) ./bin/runzope
Traceback (most recent call last):
  File "/usr/local/src/Zope-2.9.6-final/lib/python/Zope2/Startup/run.py", line 
56, in ?
  File "/usr/local/src/Zope-2.9.6-final/lib/python/Zope2/Startup/run.py", line 
21, in run
  File "/usr/local/src/Zope-2.9.6-final/lib/python/Zope2/Startup/__init__.py", 
line 98, in prepare
  File "/usr/local/src/Zope-2.9.6-final/lib/python/Zope2/Startup/__init__.py", 
line 257, in startZope
  File "/usr/local/src/Zope-2.9.6-final/lib/python/Zope2/__init__.py", line 47, 
in startup
  File "/usr/local/src/Zope-2.9.6-final/lib/python/Zope2/App/startup.py", line 
60, in startup
    DB = dbtab.getDatabase('/', is_root=1)
  File "/usr/local/src/Zope-2.9.6-final/lib/python/Zope2/Startup/datatypes.py", 
line 280, in getDatabase
    db = factory.open(name, self.databases)
  File "/usr/local/src/Zope-2.9.6-final/lib/python/Zope2/Startup/datatypes.py", 
line 178, in open
    DB = self.createDB(database_name, databases)
  File "/usr/local/src/Zope-2.9.6-final/lib/python/Zope2/Startup/datatypes.py", 
line 175, in createDB
    return ZODBDatabase.open(self, databases)
  File "/usr/local/src/Zope-2.9.6-final/lib/python/ZODB/config.py", line 97, in 
    storage = section.storage.open()
  File "/usr/local/src/Zope-2.9.6-final/lib/python/ZODB/config.py", line 135, 
in open
line 112, in __init__
    self._lock_file = LockFile(file_name + '.lock')
  File "/usr/local/src/Zope-2.9.6-final/lib/python/ZODB/lock_file.py", line 60, 
in __init__
    self._fp = open(path, 'w+')
IOError: [Errno 13] Permission denied: '/usr/local/www/clients/var/Data.fs.lock'

Yahoo! Music Unlimited
Access over 1 million songs.
Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to