Sorry, it seems I didn't click on the right button :), here is the message
sent to the list this time :

Thank you Andreas for showing me this nice tool which is tcpflow.

Thanks to it, I am now sure that the probleme is coming from zope.

Would you take a look at this :
[EMAIL PROTECTED]:~/HTTPCONNECTIONS# tcpflow host and port 8081
tcpflow[20104]: listening on eth0

The tcpflow is run on the machine, the one that zope thinks it
sends two times the XMLRPC query. is the server that runs zope.

Now i click on the button, on both browsers (remember they are on different
machines), invoking the method "toutCompter" via xmlhttprequest, and wait
for zope to complete the requests :

<zope trace to the console>
ip: requests counting of lines 1 to 11
ip: requests counting of lines 1 to 11
sending results to
sending results to
ip: requests counting of lines 1 to 11
sending results to
</zope trace>

Zope says he got 2 requests form and sent it the results 2
times. Ok, let's check the tcpflow then for these supposed connections :
total 8,0K
-rw-r--r-- 1 root root 873 2007-01-18 18:52
-rw-r--r-- 1 root root 607 2007-01-18 18:53

Allright, first file (machine to server):

POST /aef/rechercheMultiligne/toutCompter HTTP/1.1
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1) Gecko/20061010
Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9
Accept-Language: fr,en-us;q=0.7,en;q=0.3
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-15,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive
Content-Type: application/x-www-form-urlencoded
Content-Length: 224
Cookie: _ZopeId="58653529A2r8NuahgXc"
Pragma: no-cache
Cache-Control: no-cache


Allright, there is only ONE POST request. So zope didnt really got two
requests. Now let's see if it sent the data two times as it presumes :

HTTP/1.1 200 OK
Server: Zope/(Zope 2.9.0-, python 2.4.2, linux2) ZServer/1.1
Date: Thu, 18 Jan 2007 17:51:42 GMT
Content-Length: 413
Charset: utf-8
Content-Type: text/xml; charset=utf-8

<?xml version="1.0" encoding="utf-8" ?><comptages><comptage
numLigne="1">3</comptage><comptage numLigne="2">3</comptage><comptage
numLigne="3">3</comptage><comptage numLigne="4">3</comptage><comptage
numLigne="5">3</comptage><comptage numLigne="6">3</comptage><comptage
numLigne="7">3</comptage><comptage numLigne="8">3</comptage><comptage
numLigne="9">3</comptage><comptage numLigne="10">3</comptage></comptages>

The results were sent just one time, not two.

What is going on here ?

Any comment would be really appreciated.

Zope maillist  -
**   No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to