+-------[ amol kumbhar ]----------------------
| nt-Type: text/html; charset=ISO-8859-1 Content-Transfer-Encoding:
| quoted-printable Thanks for replying
| but I am still there .....
| My DA.py contain this list of allowed_psycopg_version :
| ALLOWED_PSYCOPG_VERSIONS = ('2.0.7','2.0.8','2.0.9')
| and the condition which is generating the ImportError from this file is :
| # check psycopg version and raise exception if does not match
| if psycopg2.__version__[:9] not in ALLOWED_PSYCOPG_VERSIONS:
| raise ImportError("psycopg version mismatch (imported %s)" %
| could you please guide me which version should I add in
| ALLOWED_PSYCOPG_VERSION list
Don't do that unless you're not particularly fond of your data. 2.0.6 is
not in this list because it contains bugs or incompatibilities with the
2.0.9 version of ZPsycopg.
You have a psycopg 2.0.6 *somewhere* (the python package, not the Zope
Either in your Zope's lib/python or in your site-packages for your python.
You need to make sure that that is *also* 2.0.9
Zope maillist - Zope@zope.org
** No cross posts or HTML encoding! **
(Related lists -