So I ended up going with Python 2.4.6 via Macports. I really want to  
get this to work with Zope 2.8... configure works fine when I use this  
python, but then when I make, I get:

"/opt/local/bin/python2.4" "/home/zope/Zope-2.8.6-final/setup.py" \
             build --build-base="/home/zope/Zope-2.8.6-final/build- 
base/python-2.4" --build-lib="/home/zope/Zope-2.8.6-final/build-base/ 
python-2.4/build-lib" --build-scripts="/home/zope/Zope-2.8.6-final/ 
build-base/python-2.4/build-scripts" --build-temp="/home/zope/ 
Zope-2.8.6-final/build-base/python-2.4/build-temp"
running build
running build_py
error: package directory 'build/lib/macosx-10/6-i386-2/4/Products/ 
StandardCacheManagers' does not exist
make: *** [build] Error 1

I see this StandardCacheManagers directory does exist in /home/zope/ 
Zope-2.8.6-final/lib/python/build/lib.macosx-10.6-i386-2.4/Products/ 
StandardCacheManagers but maybe this is not the right one? Any thoughts?

Thanks,

Dan

On Dec 23, 2010, at 10:10 AM, Dan Gaibel wrote:

> I apologize if this questions belongs in a different forum, but...
>
> I am having a heck of a time getting Python 2.3.5 installed in OS X
> 10.6 (Snow Leopard server.) I need it for a Zope 2.8.6 installation.
> OS X comes with Python 2.6.1 and I guess my plan is to have 2.3
> installed alongside it.
>
> Neither MacPorts (a framework for installing ports of various programs
> to os x) nor Fink (essentially a port of apt-get / dpkg for os x)
> worked. MacPorts didn't have a port of python2.3 and Fink wouldn't
> compile.
>
> What I did to get it to the point where it is now:
>
> configure with:
>
> ./configure --enable-framework MACOSX_DEPLOYMENT_TARGET=10.5 --with-
> universal-archs=all --enable-toolbox-glue=false
>
> then run:
>
> export LC_CTYPE=en_US.UTF-8
>
> next edit the resulting Makefile and remove the -Wno-long-double flag
> (it only appears once)
>
> finally, running 'sudo make' yields the error:
>
> libtool -o Python.framework/Versions/2.3/Python -dynamic -prebind -
> seg1addr 0x10000000 libpython2.3.a \
>                 -framework System -lcc_dynamic -arch_only ppc  -
> install_name /Library/Frameworks/Python.framework/Versions/2.3/ 
> Python -
> compatibility_version 2.3 -current_version 2.3
> libtool: can't locate file for: -lcc_dynamic
> libtool: file: -lcc_dynamic is not an object file (not allowed in a
> library)
> make: *** [Python.framework/Versions/2.3/Python] Error 1
>
> I haven't been able to figure out that last error; commenting out the
> line it stems from breaks things, deleting just that particular flag
> (lcc_dynamic) breaks things, and googling didn't turn up any answers.
>
> If this is an inappropriate questions for this list, I apologize...
> where should I post?
>
> Thanks!
>
> Dan
> _______________________________________________
> Zope maillist  -  Zope@zope.org
> https://mail.zope.org/mailman/listinfo/zope
> **   No cross posts or HTML encoding!  **
> (Related lists -
> https://mail.zope.org/mailman/listinfo/zope-announce
> https://mail.zope.org/mailman/listinfo/zope-dev )

_______________________________________________
Zope maillist  -  Zope@zope.org
https://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to