As luck would have it, I found Zope 2.8 in Macports. Ran  
mkzopeinstance without trouble, but starting up zopectl yields:

Traceback (most recent call last):
   File "/opt/local/libexec/Zope/lib/python/Zope2/Startup/zopectl.py",  
line 322, in <module>
     main()
   File "/opt/local/libexec/Zope/lib/python/Zope2/Startup/zopectl.py",  
line 280, in main
     options.realize(args)
   File "/opt/local/libexec/Zope/lib/python/Zope2/Startup/zopectl.py",  
line 91, in realize
     ZDOptions.realize(self, *args, **kw)
   File "/opt/local/libexec/Zope/lib/python/zdaemon/zdoptions.py",  
line 273, in realize
     self.load_schema()
   File "/opt/local/libexec/Zope/lib/python/zdaemon/zdoptions.py",  
line 321, in load_schema
     self.schema = ZConfig.loadSchema(self.schemafile)
   File "/opt/local/libexec/Zope/lib/python/ZConfig/loader.py", line  
31, in loadSchema
     return SchemaLoader().loadURL(url)
   File "/opt/local/libexec/Zope/lib/python/ZConfig/loader.py", line  
65, in loadURL
     return self.loadResource(r)
   File "/opt/local/libexec/Zope/lib/python/ZConfig/loader.py", line  
159, in loadResource
     schema = ZConfig.schema.parseResource(resource, self)
   File "/opt/local/libexec/Zope/lib/python/ZConfig/schema.py", line  
27, in parseResource
     xml.sax.parse(resource.file, parser)
   File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/ 
lib/python2.6/xml/sax/__init__.py", line 33, in parse
     parser.parse(source)
   File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/ 
lib/python2.6/xml/sax/expatreader.py", line 107, in parse
     xmlreader.IncrementalParser.parse(self, source)
   File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/ 
lib/python2.6/xml/sax/xmlreader.py", line 123, in parse
     self.feed(buffer)
   File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/ 
lib/python2.6/xml/sax/expatreader.py", line 207, in feed
     self._parser.Parse(data, isFinal)
   File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/ 
lib/python2.6/xml/sax/expatreader.py", line 301, in start_element
     self._cont_handler.startElement(name, AttributesImpl(attrs))
   File "/opt/local/libexec/Zope/lib/python/ZConfig/schema.py", line  
103, in startElement
     getattr(self, "start_" + name)(attrs)
   File "/opt/local/libexec/Zope/lib/python/ZConfig/schema.py", line  
306, in start_import
     src = self._loader.schemaComponentSource(pkg, file)
   File "/opt/local/libexec/Zope/lib/python/ZConfig/loader.py", line  
176, in schemaComponentSource
     __import__(package)
   File "/opt/local/libexec/Zope/lib/python/ZServer/__init__.py", line  
41, in <module>
     from HTTPServer import zhttp_server, zhttp_handler
   File "/opt/local/libexec/Zope/lib/python/ZServer/HTTPServer.py",  
line 45, in <module>
     from HTTPResponse import make_response
   File "/opt/local/libexec/Zope/lib/python/ZServer/HTTPResponse.py",  
line 23, in <module>
     from ZPublisher.HTTPResponse import HTTPResponse
   File "/opt/local/libexec/Zope/lib/python/ZPublisher/__init__.py",  
line 24, in <module>
     from Publish import publish_module, Retry
   File "/opt/local/libexec/Zope/lib/python/ZPublisher/Publish.py",  
line 20, in <module>
     from Request import Request
   File "/opt/local/libexec/Zope/lib/python/ZPublisher/Request.py",  
line 13, in <module>
     import HTTPRequest
   File "/opt/local/libexec/Zope/lib/python/ZPublisher/ 
HTTPRequest.py", line 18, in <module>
     from BaseRequest import BaseRequest
   File "/opt/local/libexec/Zope/lib/python/ZPublisher/ 
BaseRequest.py", line 41, in <module>
     from AccessControl.ZopeSecurityPolicy import getRoles
   File "/opt/local/libexec/Zope/lib/python/AccessControl/ 
__init__.py", line 17, in <module>
     from Implementation import setImplementation
   File "/opt/local/libexec/Zope/lib/python/AccessControl/ 
Implementation.py", line 98, in <module>
     setImplementation("C")
   File "/opt/local/libexec/Zope/lib/python/AccessControl/ 
Implementation.py", line 51, in setImplementation
     from AccessControl import ImplC as impl
   File "/opt/local/libexec/Zope/lib/python/AccessControl/ImplC.py",  
line 18, in <module>
     from cAccessControl import rolesForPermissionOn, \
   File "/opt/local/libexec/Zope/lib/python/AccessControl/ 
SimpleObjectPolicies.py", line 82, in <module>
     from DocumentTemplate.DT_Util import TemplateDict
   File "/opt/local/libexec/Zope/lib/python/DocumentTemplate/ 
__init__.py", line 21, in <module>
     from DocumentTemplate import String, File, HTML, HTMLDefault,  
HTMLFile
   File "/opt/local/libexec/Zope/lib/python/DocumentTemplate/ 
DocumentTemplate.py", line 112, in <module>
     from DT_String import String, File
   File "/opt/local/libexec/Zope/lib/python/DocumentTemplate/ 
DT_String.py", line 19, in <module>
     from DT_Util import ParseError, InstanceDict, TemplateDict,  
render_blocks, str
   File "/opt/local/libexec/Zope/lib/python/DocumentTemplate/ 
DT_Util.py", line 19, in <module>
     from html_quote import html_quote, ustr # for import by other  
modules, dont remove!
   File "/opt/local/libexec/Zope/lib/python/DocumentTemplate/ 
html_quote.py", line 4, in <module>
     from ustr import ustr
   File "/opt/local/libexec/Zope/lib/python/DocumentTemplate/ustr.py",  
line 18, in <module>
     nasty_exception_str = Exception.__str__.im_func
AttributeError: 'wrapper_descriptor' object has no attribute 'im_func'

Does this make sense to anyone? Has anyone had any luck with Macports  
(using zope) under os x 10.6 (Snow Leopard?)

Any advice is GREATLY appreciated.

Dan

On Jan 5, 2011, at 12:23 PM, Dan Gaibel wrote:

> So I ended up going with Python 2.4.6 via Macports. I really want to
> get this to work with Zope 2.8... configure works fine when I use this
> python, but then when I make, I get:
>
> "/opt/local/bin/python2.4" "/home/zope/Zope-2.8.6-final/setup.py" \
>             build --build-base="/home/zope/Zope-2.8.6-final/build-
> base/python-2.4" --build-lib="/home/zope/Zope-2.8.6-final/build-base/
> python-2.4/build-lib" --build-scripts="/home/zope/Zope-2.8.6-final/
> build-base/python-2.4/build-scripts" --build-temp="/home/zope/
> Zope-2.8.6-final/build-base/python-2.4/build-temp"
> running build
> running build_py
> error: package directory 'build/lib/macosx-10/6-i386-2/4/Products/
> StandardCacheManagers' does not exist
> make: *** [build] Error 1
>
> I see this StandardCacheManagers directory does exist in /home/zope/
> Zope-2.8.6-final/lib/python/build/lib.macosx-10.6-i386-2.4/Products/
> StandardCacheManagers but maybe this is not the right one? Any  
> thoughts?
>
> Thanks,
>
> Dan
>
> On Dec 23, 2010, at 10:10 AM, Dan Gaibel wrote:
>
>> I apologize if this questions belongs in a different forum, but...
>>
>> I am having a heck of a time getting Python 2.3.5 installed in OS X
>> 10.6 (Snow Leopard server.) I need it for a Zope 2.8.6 installation.
>> OS X comes with Python 2.6.1 and I guess my plan is to have 2.3
>> installed alongside it.
>>
>> Neither MacPorts (a framework for installing ports of various  
>> programs
>> to os x) nor Fink (essentially a port of apt-get / dpkg for os x)
>> worked. MacPorts didn't have a port of python2.3 and Fink wouldn't
>> compile.
>>
>> What I did to get it to the point where it is now:
>>
>> configure with:
>>
>> ./configure --enable-framework MACOSX_DEPLOYMENT_TARGET=10.5 --with-
>> universal-archs=all --enable-toolbox-glue=false
>>
>> then run:
>>
>> export LC_CTYPE=en_US.UTF-8
>>
>> next edit the resulting Makefile and remove the -Wno-long-double flag
>> (it only appears once)
>>
>> finally, running 'sudo make' yields the error:
>>
>> libtool -o Python.framework/Versions/2.3/Python -dynamic -prebind -
>> seg1addr 0x10000000 libpython2.3.a \
>>                -framework System -lcc_dynamic -arch_only ppc  -
>> install_name /Library/Frameworks/Python.framework/Versions/2.3/
>> Python -
>> compatibility_version 2.3 -current_version 2.3
>> libtool: can't locate file for: -lcc_dynamic
>> libtool: file: -lcc_dynamic is not an object file (not allowed in a
>> library)
>> make: *** [Python.framework/Versions/2.3/Python] Error 1
>>
>> I haven't been able to figure out that last error; commenting out the
>> line it stems from breaks things, deleting just that particular flag
>> (lcc_dynamic) breaks things, and googling didn't turn up any answers.
>>
>> If this is an inappropriate questions for this list, I apologize...
>> where should I post?
>>
>> Thanks!
>>
>> Dan
>> _______________________________________________
>> Zope maillist  -  Zope@zope.org
>> https://mail.zope.org/mailman/listinfo/zope
>> **   No cross posts or HTML encoding!  **
>> (Related lists -
>> https://mail.zope.org/mailman/listinfo/zope-announce
>> https://mail.zope.org/mailman/listinfo/zope-dev )
>
> _______________________________________________
> Zope maillist  -  Zope@zope.org
> https://mail.zope.org/mailman/listinfo/zope
> **   No cross posts or HTML encoding!  **
> (Related lists -
> https://mail.zope.org/mailman/listinfo/zope-announce
> https://mail.zope.org/mailman/listinfo/zope-dev )

_______________________________________________
Zope maillist  -  Zope@zope.org
https://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to