> I approve conditionally. There are still some things that require fixing: > > 1. If the options are validated using a schema, there is no need to transform > them to > lower case because the schema is case-sensitive. Also, the code should > validate the namespace of the node, not only the local name. Fixed.
> 2. Why is x:canonicalize#1 not implemented on x:canonicalize#2 by specifying > the default options in XQuery. XML_PARSE_NOERROR is the only option set by default but this is mandatory for the error handling. The XQDoc documentation was updated to state this fact. > 3. x:canonicalize-options-impl needs documentation and should be named > x:canonicalize-impl instead. I think (but I'm not sure) that it doesn't go > through > the RQ if the private function doesn't have sufficient parameter > documentation. Done the renaming. The RQ runs the moduleDocumentation test that checks the XQDoc comments for all public functions *only*. -- https://code.launchpad.net/~zorba-coders/zorba/canonicalize-core-fixed/+merge/142394 Your team Zorba Coders is subscribed to branch lp:zorba. -- Mailing list: https://launchpad.net/~zorba-coders Post to : firstname.lastname@example.org Unsubscribe : https://launchpad.net/~zorba-coders More help : https://help.launchpad.net/ListHelp