Have a google for a post I made a while back to the zope3-dev@zope.org list saying thankyou for the amazing packaging work they did for the new ZPT.

There were a few mails in the thread and one of them showed the exact steps I used to produce the tarballs and windows installers I worked with...


If those steps no longer work, ask on zope3-dev@zope.org, the people there are usually pretty responsive...

cheers,

Chris

Ian Bicking wrote:
OK, I've long put off installing a modern ZPT, instead relying on zpt.sf.net, and I thought I'd resolve that. But I can't figure out where to get the darn thing. One bit of instruction I found was to do this:

$ svn co svn://svn.zope.org/repos/main/zpkgtools/trunk zpkgtools
$ cd zpkgtools
$ ./bin/zpkg --resource-map=svn://svn.zope.org/repos/main/ReleaseSupport/trunk/PackageMaps/zope3.map -ca ZPT could not load from svn://svn.zope.org/repos/main/Zope3/trunk/src/zope/testing (exit code 1)
----
temporary files are in /tmp/zpkg-SjKHWY


And there are some useful-looking files in there, like /tmp/zpkg-SjKHWY/ZPT-0.0.0/Dependencies/zope.pagetemplate-ZPT-0.0.0/ almost looks like a proper package. When I install it there's no zope/__init__.py file, though. I tried installing zope-ZPT-0.0.0/ which puts the zope/__init__.py file in place, but no luck.

So what's the deal? Something should really be on http://www.zope.org/DevHome/Wikis/DevSite/Projects/ZPT/FrontPage too.


--
Simplistix - Content Management, Zope & Python Consulting
           - http://www.simplistix.co.uk

_______________________________________________
ZPT mailing list
ZPT@zope.org
http://mail.zope.org/mailman/listinfo/zpt

Reply via email to