Your question was very good. My only criticism of the way you asked you question is the vague title of the post. Ask as many questions like this per day as you want.

change the following:
- (id) directoryTable: (NSTableView *) aTableView
objectValueForTableColumn:(NSTableColumn *) aTableColumn row: (int)
rowIndex
{
   NSLog(@"Row index is %d", rowIndex);

   NSString *file = [arrayOfFiles objectAtIndex:rowIndex];
   return [file self];
}

to this:

- (id)tableView:(NSTableView *)aTableView
    objectValueForTableColumn:(NSTableColumn *)aTableColumn
    row:(int)rowIndex
{
   NSLog(@"Row index is %d", rowIndex);

   NSString *file = [arrayOfFiles objectAtIndex:rowIndex];
   return file;
}
A data source can be any object you specify, but the names of the data source methods are not optional. You must provide the correctly named methods.

http://developer.apple.com/documentation/Cocoa/Conceptual/TableView/Tasks/UsingTableDataSource.html#/ /apple_ref/doc/uid/20000117

By changing the name of the method, you provided no way for the NSTableView to find the needed data.

_______________________________________________

Cocoa-dev mailing list (Cocoa-dev@lists.apple.com)

Please do not post admin requests or moderator comments to the list.
Contact the moderators at cocoa-dev-admins(at)lists.apple.com

Help/Unsubscribe/Update your Subscription:
http://lists.apple.com/mailman/options/cocoa-dev/archive%40mail-archive.com

This email sent to [EMAIL PROTECTED]

Reply via email to