Hi Laruence

2013/3/31 Laruence <larue...@php.net>
>    I propose to add a constant : bool CURL_WRAPPERS_ENABLE
>
>    or, any other better name...
>
>    objections?

I'm a -1 on this, because as we sort of agreed on (like Hannes
implied), this experimental feature did not turn out as we wanted, its
buggy and nobody maintains it. Currently to figure out if PHP was
built with curlwrappers, theres this dirty hack by printing the
phpinfo() page into an output buffer, to parse it for the build
string, this sucks.

However, since this is an experimental feature, we should either:
1) Make it work (most unlikely)
2) Remove it

Instead of adding tiny hacks to make it easier (I know a constant wont
hurt much). Cross version code is also gonna end up with even more
clutter, imagine this (if you want to utilize this new constant, which
is the idea right?):

$curlwrappers = false;

if(defined('CURL_WRAPPERS_ENABLED')) {
 $curlwrappers = true;
} else {
 ob_start();
 phpinfo(INFO_GENERAL);

 if(strpos('with-curlwrappers', ob_get_clean()) !== false) {
  $curlwrappers = true;
 }
}

What I'm saying is (like Hannes), adding a constant thats only gonna
be available for one minor version, is not worth it, we lived years
without it and we can live a little longer until it finally dies.



Also, seeing you already added the constant, it should be named
CURL_WRAPPERS_ENABLED, not ENABLE because it implies that its an
option used in a write context, where this constant is purely meant to
be used in a read context.



--
regards,

Kalle Sommer Nielsen
ka...@php.net

-- 
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to