On Fri, 07 Dec 2007 14:40:43 +0300
Andrey Gusev <[EMAIL PROTECTED]> wrote:

> There my modified patch to directory existence check, this variant
> more aestetic,
> and in addition - keeps primary UpdateListing() formal specification 
> untouched
> (though to that we may spit, because UpdateListing() currently used
> only within directorycacher).
> It must be useful, besides directory existence check in compiler
> options dialog, because
> directory can be renamed outside of design process (imperceptibly to 
> IDE).
> 
> With this correction, IDE bring message about directory non-existence 
> only with first
> attempt to non-existent directory access, and "unit not found" (as 
> before) with next attempts.

Instead of IncludeTrailingPathDelimiter there is already
AppendPathDelim. Probably you have a old file because of a svn
conflict. Remove the file and update svn, or use svn revert.

The 'if not DirectoryExists(Directory)' does not work on automounted
directories. You must use FindFirst.


Mattias

_________________________________________________________________
     To unsubscribe: mail [EMAIL PROTECTED] with
                "unsubscribe" as the Subject
   archives at http://www.lazarus.freepascal.org/mailarchives

Reply via email to