From: Rafael J. Wysocki <rafael.j.wyso...@intel.com>

Move some duplicated code from acpi_bind_one() and acpi_unbind_one()
into a separate function and make that function use snprintf()
instead of sprintf() for extra safety.

Signed-off-by: Rafael J. Wysocki <rafael.j.wyso...@intel.com>
---
 drivers/acpi/glue.c |   22 +++++++++++-----------
 1 file changed, 11 insertions(+), 11 deletions(-)

Index: linux-pm/drivers/acpi/glue.c
===================================================================
--- linux-pm.orig/drivers/acpi/glue.c
+++ linux-pm/drivers/acpi/glue.c
@@ -108,6 +108,15 @@ acpi_handle acpi_get_child(acpi_handle p
 }
 EXPORT_SYMBOL(acpi_get_child);
 
+static void acpi_bind_physnode_name(char *buf, unsigned int node_id)
+{
+       if (node_id > 0)
+               snprintf(buf, PHYSICAL_NODE_NAME_SIZE,
+                        PHYSICAL_NODE_STRING "%u", node_id);
+       else
+               strcpy(buf, PHYSICAL_NODE_STRING);
+}
+
 int acpi_bind_one(struct device *dev, acpi_handle handle)
 {
        struct acpi_device *acpi_dev;
@@ -173,11 +182,7 @@ int acpi_bind_one(struct device *dev, ac
        if (!ACPI_HANDLE(dev))
                ACPI_HANDLE_SET(dev, acpi_dev->handle);
 
-       if (!physical_node->node_id)
-               strcpy(physical_node_name, PHYSICAL_NODE_STRING);
-       else
-               sprintf(physical_node_name,
-                       "physical_node%d", physical_node->node_id);
+       acpi_bind_physnode_name(physical_node_name, node_id);
        retval = sysfs_create_link(&acpi_dev->dev.kobj, &dev->kobj,
                        physical_node_name);
        retval = sysfs_create_link(&dev->kobj, &acpi_dev->dev.kobj,
@@ -231,12 +236,7 @@ int acpi_unbind_one(struct device *dev)
 
                acpi_dev->physical_node_count--;
 
-               if (!entry->node_id)
-                       strcpy(physical_node_name, PHYSICAL_NODE_STRING);
-               else
-                       sprintf(physical_node_name,
-                               "physical_node%d", entry->node_id);
-
+               acpi_bind_physnode_name(physical_node_name, entry->node_id);
                sysfs_remove_link(&acpi_dev->dev.kobj, physical_node_name);
                sysfs_remove_link(&dev->kobj, "firmware_node");
                ACPI_HANDLE_SET(dev, NULL);

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to