On 5/29/19 6:28 AM, Hannes Reinecke wrote:
+       rq = blk_mq_alloc_request(sdev->request_queue,
+                                 REQ_OP_SCSI_OUT | REQ_NOWAIT,
+                                 BLK_MQ_REQ_RESERVED);

This looks wrong to me. To avoid that blk_mq_alloc_request() waits I think it should be called as follows:

        rq = blk_mq_alloc_request(sdev->request_queue,
                        REQ_OP_SCSI_OUT,
                        BLK_MQ_REQ_RESERVED | BLK_MQ_REQ_NOWAIT);

Bart.

Reply via email to