On 5/29/19 5:12 PM, Bart Van Assche wrote:
On 5/29/19 6:28 AM, Hannes Reinecke wrote:
+    rq = blk_mq_alloc_request(sdev->request_queue,
+                  REQ_OP_SCSI_OUT | REQ_NOWAIT,
+                  BLK_MQ_REQ_RESERVED);

This looks wrong to me. To avoid that blk_mq_alloc_request() waits I think it should be called as follows:

     rq = blk_mq_alloc_request(sdev->request_queue,
             REQ_OP_SCSI_OUT,
             BLK_MQ_REQ_RESERVED | BLK_MQ_REQ_NOWAIT);

Bart.
Ah. Right.
Will be changing it.

Cheers,

Hannes
--
Dr. Hannes Reinecke            Teamlead Storage & Networking
h...@suse.de                              +49 911 74053 688
SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nürnberg
GF: Felix Imendörffer, Mary Higgins, Sri Rasiah
HRB 21284 (AG Nürnberg)

Reply via email to