Hi folks!

I'm brand new to this list, so apologies if this is an inappropriate newbie question, or is otherwise incorrect, but here goes.

I'm working with a bunch of pig scripts, and we're adding new ones almost daily. They are getting more and more complex. The problem is exacerbated by the proliferation of magic numbers throughout them. As a software engineer, these are driving me nuts! The code is quite brittle. There seems to be no way to centralize logic or even values.

For a simple example:
filtered_stuff = FILTER stuff by record_type == 23;

I'd prefer:
filtered_stuff = FILTER stuff by record_type == RECORD_TYPE_ALPHA;

Where RECORD_TYPE_ALPHA is defined in some other file that the pig script consumes.

Sounds rather like the old C-style header files would be in order...

Am I missing something obvious here? How do you guys handle this problem? (We're using pig 6 and are just starting to transition to pig 7.)

Thanks! --- Eric Wadsworth

Reply via email to