Re: [asterisk-dev] [Code Review] 4598: Refactor duplicated DNS routines into common sections

2015-04-09 Thread Mark Michelson

---
This is an automatically generated e-mail. To reply, visit:
https://reviewboard.asterisk.org/r/4598/
---

(Updated April 9, 2015, 10:50 a.m.)


Status
--

This change has been marked as submitted.


Review request for Asterisk Developers.


Changes
---

Committed in revision 434490


Repository: Asterisk


Description
---

Josh worked on SRV in one branch, and I worked on NAPTR in a separate branch. 
Independently we kept coming to realizations that something that one of us had 
developed independently would be needed by the other person. We decided to 
simply have copies of common functionality in our branches. After merging, we 
would perform a refactor to remove duplication.

This changeset introduces no new DNS functionality. Instead, it takes some 
duplicated code and places them into common areas of the DNS core.


Diffs
-

  /trunk/tests/test_dns_srv.c 434218 
  /trunk/tests/test_dns_naptr.c 434218 
  /trunk/main/dns_test.c PRE-CREATION 
  /trunk/main/dns_srv.c 434218 
  /trunk/main/dns_naptr.c 434218 
  /trunk/main/dns_core.c 434218 
  /trunk/include/asterisk/dns_test.h PRE-CREATION 
  /trunk/include/asterisk/dns_internal.h 434218 

Diff: https://reviewboard.asterisk.org/r/4598/diff/


Testing
---

All DNS unit tests continue to pass.


Thanks,

Mark Michelson

-- 
_
-- Bandwidth and Colocation Provided by http://www.api-digital.com --

asterisk-dev mailing list
To UNSUBSCRIBE or update options visit:
   http://lists.digium.com/mailman/listinfo/asterisk-dev

Re: [asterisk-dev] [Code Review] 4598: Refactor duplicated DNS routines into common sections

2015-04-08 Thread Joshua Colp

---
This is an automatically generated e-mail. To reply, visit:
https://reviewboard.asterisk.org/r/4598/#review15131
---

Ship it!


Ship It!

- Joshua Colp


On April 7, 2015, 5:49 p.m., Mark Michelson wrote:
 
 ---
 This is an automatically generated e-mail. To reply, visit:
 https://reviewboard.asterisk.org/r/4598/
 ---
 
 (Updated April 7, 2015, 5:49 p.m.)
 
 
 Review request for Asterisk Developers.
 
 
 Repository: Asterisk
 
 
 Description
 ---
 
 Josh worked on SRV in one branch, and I worked on NAPTR in a separate branch. 
 Independently we kept coming to realizations that something that one of us 
 had developed independently would be needed by the other person. We decided 
 to simply have copies of common functionality in our branches. After merging, 
 we would perform a refactor to remove duplication.
 
 This changeset introduces no new DNS functionality. Instead, it takes some 
 duplicated code and places them into common areas of the DNS core.
 
 
 Diffs
 -
 
   /trunk/tests/test_dns_srv.c 434218 
   /trunk/tests/test_dns_naptr.c 434218 
   /trunk/main/dns_test.c PRE-CREATION 
   /trunk/main/dns_srv.c 434218 
   /trunk/main/dns_naptr.c 434218 
   /trunk/main/dns_core.c 434218 
   /trunk/include/asterisk/dns_test.h PRE-CREATION 
   /trunk/include/asterisk/dns_internal.h 434218 
 
 Diff: https://reviewboard.asterisk.org/r/4598/diff/
 
 
 Testing
 ---
 
 All DNS unit tests continue to pass.
 
 
 Thanks,
 
 Mark Michelson
 


-- 
_
-- Bandwidth and Colocation Provided by http://www.api-digital.com --

asterisk-dev mailing list
To UNSUBSCRIBE or update options visit:
   http://lists.digium.com/mailman/listinfo/asterisk-dev

Re: [asterisk-dev] [Code Review] 4598: Refactor duplicated DNS routines into common sections

2015-04-07 Thread Kevin Harwell

---
This is an automatically generated e-mail. To reply, visit:
https://reviewboard.asterisk.org/r/4598/#review15092
---



/team/group/dns/main/dns_test.c
https://reviewboard.asterisk.org/r/4598/#comment25772

Consider saving the string length to a variable so you won't have to 
calculate it several times.



/trunk/main/dns_core.c
https://reviewboard.asterisk.org/r/4598/#comment25769

No value is set on true.



/trunk/main/dns_naptr.c
https://reviewboard.asterisk.org/r/4598/#comment25770

Extraneous merge nomenclature.


- Kevin Harwell


On April 6, 2015, 5:46 p.m., Mark Michelson wrote:
 
 ---
 This is an automatically generated e-mail. To reply, visit:
 https://reviewboard.asterisk.org/r/4598/
 ---
 
 (Updated April 6, 2015, 5:46 p.m.)
 
 
 Review request for Asterisk Developers.
 
 
 Repository: Asterisk
 
 
 Description
 ---
 
 Josh worked on SRV in one branch, and I worked on NAPTR in a separate branch. 
 Independently we kept coming to realizations that something that one of us 
 had developed independently would be needed by the other person. We decided 
 to simply have copies of common functionality in our branches. After merging, 
 we would perform a refactor to remove duplication.
 
 This changeset introduces no new DNS functionality. Instead, it takes some 
 duplicated code and places them into common areas of the DNS core.
 
 
 Diffs
 -
 
   /trunk/tests/test_dns_srv.c 434186 
   /trunk/tests/test_dns_naptr.c 434186 
   /trunk/main/dns_srv.c 434186 
   /trunk/main/dns_naptr.c 434186 
   /trunk/main/dns_core.c 434186 
   /trunk/include/asterisk/dns_internal.h 434186 
   /team/group/dns/main/dns_test.c PRE-CREATION 
   /team/group/dns/include/asterisk/dns_test.h PRE-CREATION 
 
 Diff: https://reviewboard.asterisk.org/r/4598/diff/
 
 
 Testing
 ---
 
 All DNS unit tests continue to pass.
 
 
 Thanks,
 
 Mark Michelson
 


-- 
_
-- Bandwidth and Colocation Provided by http://www.api-digital.com --

asterisk-dev mailing list
To UNSUBSCRIBE or update options visit:
   http://lists.digium.com/mailman/listinfo/asterisk-dev

Re: [asterisk-dev] [Code Review] 4598: Refactor duplicated DNS routines into common sections

2015-04-07 Thread Mark Michelson

---
This is an automatically generated e-mail. To reply, visit:
https://reviewboard.asterisk.org/r/4598/
---

(Updated April 7, 2015, 5:49 p.m.)


Review request for Asterisk Developers.


Changes
---

Addressed Kevin's comments.


Repository: Asterisk


Description
---

Josh worked on SRV in one branch, and I worked on NAPTR in a separate branch. 
Independently we kept coming to realizations that something that one of us had 
developed independently would be needed by the other person. We decided to 
simply have copies of common functionality in our branches. After merging, we 
would perform a refactor to remove duplication.

This changeset introduces no new DNS functionality. Instead, it takes some 
duplicated code and places them into common areas of the DNS core.


Diffs (updated)
-

  /trunk/tests/test_dns_srv.c 434218 
  /trunk/tests/test_dns_naptr.c 434218 
  /trunk/main/dns_test.c PRE-CREATION 
  /trunk/main/dns_srv.c 434218 
  /trunk/main/dns_naptr.c 434218 
  /trunk/main/dns_core.c 434218 
  /trunk/include/asterisk/dns_test.h PRE-CREATION 
  /trunk/include/asterisk/dns_internal.h 434218 

Diff: https://reviewboard.asterisk.org/r/4598/diff/


Testing
---

All DNS unit tests continue to pass.


Thanks,

Mark Michelson

-- 
_
-- Bandwidth and Colocation Provided by http://www.api-digital.com --

asterisk-dev mailing list
To UNSUBSCRIBE or update options visit:
   http://lists.digium.com/mailman/listinfo/asterisk-dev

Re: [asterisk-dev] [Code Review] 4598: Refactor duplicated DNS routines into common sections

2015-04-07 Thread Mark Michelson


 On April 7, 2015, 5:28 p.m., Kevin Harwell wrote:
  /trunk/main/dns_core.c, line 438
  https://reviewboard.asterisk.org/r/4598/diff/1/?file=73671#file73671line438
 
  No value is set on true.

This is intended. See

https://gcc.gnu.org/onlinedocs/gcc/Conditionals.html


- Mark


---
This is an automatically generated e-mail. To reply, visit:
https://reviewboard.asterisk.org/r/4598/#review15092
---


On April 6, 2015, 10:46 p.m., Mark Michelson wrote:
 
 ---
 This is an automatically generated e-mail. To reply, visit:
 https://reviewboard.asterisk.org/r/4598/
 ---
 
 (Updated April 6, 2015, 10:46 p.m.)
 
 
 Review request for Asterisk Developers.
 
 
 Repository: Asterisk
 
 
 Description
 ---
 
 Josh worked on SRV in one branch, and I worked on NAPTR in a separate branch. 
 Independently we kept coming to realizations that something that one of us 
 had developed independently would be needed by the other person. We decided 
 to simply have copies of common functionality in our branches. After merging, 
 we would perform a refactor to remove duplication.
 
 This changeset introduces no new DNS functionality. Instead, it takes some 
 duplicated code and places them into common areas of the DNS core.
 
 
 Diffs
 -
 
   /trunk/tests/test_dns_srv.c 434186 
   /trunk/tests/test_dns_naptr.c 434186 
   /trunk/main/dns_srv.c 434186 
   /trunk/main/dns_naptr.c 434186 
   /trunk/main/dns_core.c 434186 
   /trunk/include/asterisk/dns_internal.h 434186 
   /team/group/dns/main/dns_test.c PRE-CREATION 
   /team/group/dns/include/asterisk/dns_test.h PRE-CREATION 
 
 Diff: https://reviewboard.asterisk.org/r/4598/diff/
 
 
 Testing
 ---
 
 All DNS unit tests continue to pass.
 
 
 Thanks,
 
 Mark Michelson
 


-- 
_
-- Bandwidth and Colocation Provided by http://www.api-digital.com --

asterisk-dev mailing list
To UNSUBSCRIBE or update options visit:
   http://lists.digium.com/mailman/listinfo/asterisk-dev

Re: [asterisk-dev] [Code Review] 4598: Refactor duplicated DNS routines into common sections

2015-04-07 Thread Kevin Harwell

---
This is an automatically generated e-mail. To reply, visit:
https://reviewboard.asterisk.org/r/4598/#review15116
---

Ship it!



/trunk/main/dns_test.c
https://reviewboard.asterisk.org/r/4598/#comment25786

moar nitpicking :-) this could be changed to actual_len as well if you were 
so inclined.


- Kevin Harwell


On April 7, 2015, 12:49 p.m., Mark Michelson wrote:
 
 ---
 This is an automatically generated e-mail. To reply, visit:
 https://reviewboard.asterisk.org/r/4598/
 ---
 
 (Updated April 7, 2015, 12:49 p.m.)
 
 
 Review request for Asterisk Developers.
 
 
 Repository: Asterisk
 
 
 Description
 ---
 
 Josh worked on SRV in one branch, and I worked on NAPTR in a separate branch. 
 Independently we kept coming to realizations that something that one of us 
 had developed independently would be needed by the other person. We decided 
 to simply have copies of common functionality in our branches. After merging, 
 we would perform a refactor to remove duplication.
 
 This changeset introduces no new DNS functionality. Instead, it takes some 
 duplicated code and places them into common areas of the DNS core.
 
 
 Diffs
 -
 
   /trunk/tests/test_dns_srv.c 434218 
   /trunk/tests/test_dns_naptr.c 434218 
   /trunk/main/dns_test.c PRE-CREATION 
   /trunk/main/dns_srv.c 434218 
   /trunk/main/dns_naptr.c 434218 
   /trunk/main/dns_core.c 434218 
   /trunk/include/asterisk/dns_test.h PRE-CREATION 
   /trunk/include/asterisk/dns_internal.h 434218 
 
 Diff: https://reviewboard.asterisk.org/r/4598/diff/
 
 
 Testing
 ---
 
 All DNS unit tests continue to pass.
 
 
 Thanks,
 
 Mark Michelson
 


-- 
_
-- Bandwidth and Colocation Provided by http://www.api-digital.com --

asterisk-dev mailing list
To UNSUBSCRIBE or update options visit:
   http://lists.digium.com/mailman/listinfo/asterisk-dev