[webkit-dev] Update on commit messages (was: Re: Proposal: Commit messages should start with a one-line summary of the change)

2011-07-08 Thread Adam Roben
On Jul 1, 2011, at 10:38 AM, Adam Roben wrote:

 On Jun 30, 2011, at 7:52 PM, Darin Adler wrote:
 
 I do think that given the tools behavior you described, we should move the 
 reviewer text after the bug title and patch description paragraph, even 
 though you explicitly said that’s not what you are proposing.
 
 I think that would be a good first step. It would definitely be better than 
 what we have now from a tools perspective. And in a lot of cases these days, 
 the bug title really is a short description of the change. [1]
 
 I think these two bugs will get us started:
 http://webkit.org/b/26755 webkit-patch's commit messages are less readable 
 than commit-log-editor's
 http://webkit.org/b/63804 commit-log-editor reorders ChangeLog entries in 
 unexpected ways

These two bugs have now been fixed. (There was a little fallout from bug 26755, 
but hopefully that has been taken care of, too.)

prepare-ChangeLog now puts the bug title and URL first, then the Reviewed by 
line. commit-log-editor no longer reorders the ChangeLog contents (other than 
extracting common lines to the top of the commit message). webkit-patch now 
uses commit-log-editor to create its commit messages.

I think this has made some of our tools a lot more useful. (See, e.g., 
http://trac.webkit.org/log/trunk?rev=90579stop_rev=90540. The switch from 
the old commit messages to the new ones is quite obvious.) I think it's also a 
slight improvement in readability of ChangeLogs, as in many cases the bug title 
is a description of the change.

I'm going to drop the put a one-line summary at the top of your commit 
message suggestion for now. I think I've caused enough change for one email 
thread. :-)

-Adam

___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


Re: [webkit-dev] New page for viewing test failures on build.webkit.org

2011-07-08 Thread Adam Roben
I've been working a bit more on TestFailures over the last few weeks, and it's 
grown a few new features [1]. I encourage you to check it out if you haven't, 
and even if you have!

http://build.webkit.org/TestFailures/

-Adam

1. Including:
 * Basic support for detecting flaky tests
 * Basic support for NRWT bots
 * LocalStorage caching for sped!
 * Lists of existing bugs related to the failing tests
 * Parsing of commit messages to try to guess better which revision is guilty
 * Loading of builds that have been moved to the old-results directory
 * Crashing function names shown right on the page
 * Links to regression ranges in Trac
 * A link right on the page to file a bug about TestFailures itself

___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


[webkit-dev] Transformation of German ß to SS and Editing

2011-07-08 Thread Ryosuke Niwa
Hi all,

Editing code in general is unaware of German ß and it hits assertions or
exhibit incorrect behavior whenever there's ß and case transformation.

I'd like to fix this but I need your wisdom because I don't fully understand
how we're transforming small ß to SS in rendering engine.  Is this happening
in line layout code?  If so, where and when?

And how can we detect this in editing code?  It appears as if whenever we
see SS in RenderText, we'd have to go check if they were generated by ß
or not by looking at the corresponding Text node.

Even if the above solution worked, it seems like we'd have to add the same
hack in at least TextIterator, Position, VisiblePosition, and visible_units,
which seems quite invasive.  Maybe we should refactor these classes and
functions to share code first?

I request for your comments and suggestions.

Best,
Ryosuke Niwa
Software Engineer
Google Inc.
___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev