Parallel ClassLoading space optimizations

2013-02-04 Thread Peter Levart
Hi David, I might have something usable, but I just wanted to verify some things beforehand. What I investigated was a simple keeping a cache of locks in a map weekly referenced. In your blog: * https://blogs.oracle.com/dholmes/entry/parallel_classloading_revisited_fully_concurrent ...you

Re: RFR: race with nested repos in hgforest.sh

2013-02-04 Thread Chris Hegarty
There has been some discussion on this with David, but no other takers. Fredrik, am I right that you added the support for parallel clone/update? I believe the changes I have are correct, but maybe you had other ideas about how to solve this issue? -Chris. On 01/02/2013 14:40, Chris Hegarty

Re: geteuid(2) in java?

2013-02-04 Thread Alan Bateman
On 04/02/2013 06:38, Weijun Wang wrote: Need an equivalence of the geteuid() function that returns the effective user ID of the calling process. There isn't an API for this. -Alan

Re: RFR: race with nested repos in hgforest.sh

2013-02-04 Thread Fredrik Öhrström
2013-02-04 10:48, Chris Hegarty skrev: There has been some discussion on this with David, but no other takers. Fredrik, am I right that you added the support for parallel clone/update? I believe the changes I have are correct, but maybe you had other ideas about how to solve this issue?

Re: RFR: race with nested repos in hgforest.sh

2013-02-04 Thread Chris Hegarty
On 04/02/2013 10:04, Fredrik Öhrström wrote: 2013-02-04 10:48, Chris Hegarty skrev: There has been some discussion on this with David, but no other takers. Fredrik, am I right that you added the support for parallel clone/update? I believe the changes I have are correct, but maybe you had

Re: RFR (S) 8007142: Add utility classes for writing better multiprocess tests in jtreg

2013-02-04 Thread Yekaterina Kantserova
On 02/01/2013 04:18 PM, Alan Bateman wrote: On 01/02/2013 15:06, Yekaterina Kantserova wrote: Thanks for explanation! But I'm still confused. In my use case I need to test /_the tool_/ I'll find with JDKToolFinder. It will work if just -jdk will be specified. But if -compilejdk happens to

Re: RFR (S) 8007142: Add utility classes for writing better multiprocess tests in jtreg

2013-02-04 Thread Alan Bateman
On 04/02/2013 10:33, Yekaterina Kantserova wrote: No, it was a bad example. Let's take another one: /java -jar jtreg.jar -jdk MONKEY -compilejdk LION test.java/ In this case JDKToolFinder.getJDKTool(jcmd) will return LION/bin/jcmd, but I need to test MONKEY/bin/jcmd. The -compilejdk option

Re: RFR (S) 8007142: Add utility classes for writing better multiprocess tests in jtreg

2013-02-04 Thread Yekaterina Kantserova
On 02/04/2013 11:55 AM, Alan Bateman wrote: On 04/02/2013 10:33, Yekaterina Kantserova wrote: No, it was a bad example. Let's take another one: /java -jar jtreg.jar -jdk MONKEY -compilejdk LION test.java/ In this case JDKToolFinder.getJDKTool(jcmd) will return LION/bin/jcmd, but I need to

Re: Parallel ClassLoading space optimizations

2013-02-04 Thread David Holmes
Hi Peter, On 4/02/2013 6:42 PM, Peter Levart wrote: Hi David, I might have something usable, but I just wanted to verify some things beforehand. What I investigated was a simple keeping a cache of locks in a map weekly referenced. In your blog: *

Re: Parallel ClassLoading space optimizations

2013-02-04 Thread David Holmes
On 4/02/2013 9:11 PM, David Holmes wrote: On 4/02/2013 6:42 PM, Peter Levart wrote: I might have something usable, but I just wanted to verify some things beforehand. What I investigated was a simple keeping a cache of locks in a map weekly referenced. In your blog: *

Request for review: 8007454 Wrong parameters in Win32 native code.

2013-02-04 Thread Alexey Utkin
Hi, Please review the fix. Bug description: http://bugs.sun.com/view_bug.do?bug_id=8007454 https://jbs.oracle.com/bugs/browse/JDK-8007454 The suggested fix: http://cr.openjdk.java.net/~uta/openjdk-webrevs/JDK-8007454/webrev.01/ Summary: Old version of code for the

Re: RFR (S) 8007142: Add utility classes for writing better multiprocess tests in jtreg

2013-02-04 Thread Alan Bateman
On 04/02/2013 11:03, Yekaterina Kantserova wrote: But JDKToolFinder.getJDKTool is used even for finding java, e.g. I need to fork a java process - JDKToolFinder.getJDKTool(java) for some JRE tests? It might be better to rename JDKToolFinder to something like JdkFinder and have it define

Re: RFR : 8006594/8006595 : Define jdk_core test set

2013-02-04 Thread Alan Bateman
On 02/02/2013 20:40, Mike Duigou wrote: I have updated both the jdk repo patch: 8006594: Add jdk_core target to jdk/test/Makefile http://cr.openjdk.java.net/~mduigou/JDK-8006594/1/webrev/ and the root repo patch: 8006595: Use jdk/test/Makefile targets in preference to local definitions

Re: [Base64] Codereview request for 8006315 8006530 AND 8006295

2013-02-04 Thread Alan Bateman
On 01/02/2013 16:55, Xueming Shen wrote: Hi, For 8006295 it appears the more reasonable approach is to continue throw IOE but document this behavior clearly at the wrap(is) API. So the change is joined with these two. 8006295: Base64.Decoder.wrap(java.io.InputStream) returns InputStream

Re: Request for review: 8007454 Wrong parameters in Win32 native code.

2013-02-04 Thread Alan Bateman
On 04/02/2013 12:28, Alexey Utkin wrote: Hi, Please review the fix. Bug description: http://bugs.sun.com/view_bug.do?bug_id=8007454 https://jbs.oracle.com/bugs/browse/JDK-8007454 The suggested fix: http://cr.openjdk.java.net/~uta/openjdk-webrevs/JDK-8007454/webrev.01/ Summary: Old

Re: RFR : 8006594/8006595 : Define jdk_core test set

2013-02-04 Thread Mike Duigou
On Feb 4 2013, at 05:54 , Alan Bateman wrote: On 02/02/2013 20:40, Mike Duigou wrote: I have updated both the jdk repo patch: 8006594: Add jdk_core target to jdk/test/Makefile http://cr.openjdk.java.net/~mduigou/JDK-8006594/1/webrev/ and the root repo patch: 8006595: Use

Re: [Base64] Codereview request for 8006315 8006530 AND 8006295

2013-02-04 Thread Chris Hegarty
On 04/02/2013 14:20, Alan Bateman wrote: On 01/02/2013 16:55, Xueming Shen wrote: Hi, For 8006295 it appears the more reasonable approach is to continue throw IOE but document this behavior clearly at the wrap(is) API. So the change is joined with these two. 8006295:

Re: RFR : 8006594/8006595 : Define jdk_core test set

2013-02-04 Thread Alan Bateman
On 04/02/2013 16:02, Mike Duigou wrote: : If so then I think we have to careful because -concurrency means a lot of virtual memory and I'm not convinced that we limit it via -vmoption in jdk/test/Makefile I could see us wanting to dial this down on 32-bit Windows for example. We do limit the

Re: [Base64] Codereview request for 8006315 8006530 AND 8006295

2013-02-04 Thread Ulf Zibis
Am 04.02.2013 17:05, schrieb Chris Hegarty: On 04/02/2013 14:20, Alan Bateman wrote: On 01/02/2013 16:55, Xueming Shen wrote: Hi, For 8006295 it appears the more reasonable approach is to continue throw IOE but document this behavior clearly at the wrap(is) API. So the change is joined with

Re: [Base64] Codereview request for 8006315 8006530 AND 8006295

2013-02-04 Thread Ulf Zibis
Am 04.02.2013 17:36, schrieb Ulf Zibis: On 04/02/2013 14:20, Alan Bateman wrote: If the input byte stream is not in valid Base64 encoding scheme then IOException will be thrown when reading any invalid Base64 byte(s) from the returned input stream. Additionally there is a comma missing after

hg: jdk8/tl/jdk: 8006994: Cleanup PKCS12 tests to ensure streams get closed

2013-02-04 Thread vincent . x . ryan
Changeset: 5bf1c9e6be60 Author:vinnie Date: 2013-02-04 17:20 + URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/5bf1c9e6be60 8006994: Cleanup PKCS12 tests to ensure streams get closed Reviewed-by: mullan ! test/java/security/KeyStore/PBETest.java !

Re: Math.round(...) and bug 6430675

2013-02-04 Thread Brian Burkhalter
Thank you! Brian On Feb 2, 2013, at 1:40 AM, Jeff Hain wrote: Would you mind filing an issue so that this may be tracked? Done: Math.round has surprising behavior for odd values of ulp 1

RFR - 6480539: BigDecimal.stripTrailingZeros() should specify no-op on zero BigDecimals

2013-02-04 Thread Brian Burkhalter
Hi, While stripTrailingZeros() should perhaps for purity of specification always return BigDecimal.ZERO for anything which is numerically equal to zero, the present behavior of this method has been extant for some years, so following the prevailing convention it would be preferable to modify

Re: RFR - 6480539: BigDecimal.stripTrailingZeros() should specify no-op on zero BigDecimals

2013-02-04 Thread Stephen Colebourne
On 4 February 2013 18:09, Brian Burkhalter brian.burkhal...@oracle.com wrote: While stripTrailingZeros() should perhaps for purity of specification always return BigDecimal.ZERO for anything which is numerically equal to zero, the present behavior of this method has been extant for some

Re: RFR: race with nested repos in hgforest.sh

2013-02-04 Thread Kelly O'Hair
Looks fine to me. -kto On Feb 1, 2013, at 6:40 AM, Chris Hegarty wrote: [ to build-dev and core-libs-dev, expect reviewer from either, but will integrate through jdk8/tl ] This issue is mainly of interest to Oracle engineers, but it effects the public hgforest script. When

Re: Review Request for JDK-8007389: Remove uses of _ as identifier in jaxp

2013-02-04 Thread Joe Wang
Hi Eric, The change is fine. Thanks for taking on fixing this! Joe On 2/1/2013 3:19 PM, Eric McCorkle wrote: Thanks. Do I have a second? On 02/01/13 12:04, Lance Andersen - Oracle wrote: Its OK. Not sure I would have replaced it with 'unused' but not a big deal as it is just a personal

Re: RFR - 6480539: BigDecimal.stripTrailingZeros() should specify no-op on zero BigDecimals

2013-02-04 Thread Joe Darcy
On 2/4/2013 10:13 AM, Stephen Colebourne wrote: On 4 February 2013 18:09, Brian Burkhalter brian.burkhal...@oracle.com wrote: While stripTrailingZeros() should perhaps for purity of specification always return BigDecimal.ZERO for anything which is numerically equal to zero, the present

Re: RFR: race with nested repos in hgforest.sh

2013-02-04 Thread Ioi Lam
How about adding a message to indicate the sleep, just in case the directory is never created for whatever reason. If you don't like too many such messages, you can print the message after the initial wait. 177 while [ ! -d $path ] ## nested repo, ensure containing dir exists

Re: [Base64] Codereview request for 8006315 8006530 AND 8006295

2013-02-04 Thread Xueming Shen
Thanks Alan, Chris and Ulf for the review and comments. The wording has been updated accordingly. Hope it is clear enough for push. http://cr.openjdk.java.net/~sherman/8006295_8006315_8006530/webrev/ -Sherman On 02/04/2013 08:36 AM, Ulf Zibis wrote: Am 04.02.2013 17:05, schrieb Chris

Re: Review Request for JDK-8007389: Remove uses of _ as identifier in jaxp

2013-02-04 Thread Eric McCorkle
Thanks for the reviews everybody! On 02/04/13 14:02, Joe Wang wrote: Hi Eric, The change is fine. Thanks for taking on fixing this! Joe On 2/1/2013 3:19 PM, Eric McCorkle wrote: Thanks. Do I have a second? On 02/01/13 12:04, Lance Andersen - Oracle wrote: Its OK. Not sure I would

hg: jdk8/tl/jdk: 8006295: Base64.Decoder.wrap(java.io.InputStream) returns InputStream which throws unspecified IOException on attempt to decode invalid Base64 byte stream; ...

2013-02-04 Thread xueming . shen
Changeset: e202f43a8b8a Author:sherman Date: 2013-02-04 11:58 -0800 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/e202f43a8b8a 8006295: Base64.Decoder.wrap(java.io.InputStream) returns InputStream which throws unspecified IOException on attempt to decode invalid Base64 byte

Re: [Base64] Codereview request for 8006315 8006530 AND 8006295

2013-02-04 Thread Chris Hegarty
Looks ok to me. -Chris On 4 Feb 2013, at 19:41, Xueming Shen xueming.s...@oracle.com wrote: Thanks Alan, Chris and Ulf for the review and comments. The wording has been updated accordingly. Hope it is clear enough for push.

Re: [Base64] Codereview request for 8006315 8006530 AND 8006295

2013-02-04 Thread Ulf Zibis
Am 04.02.2013 20:41, schrieb Xueming Shen: Thanks Alan, Chris and Ulf for the review and comments. The wording has been updated accordingly. Hope it is clear enough for push. http://cr.openjdk.java.net/~sherman/8006295_8006315_8006530/webrev/ The wording now looks perfect to me! A similar

Re: RFR: race with nested repos in hgforest.sh

2013-02-04 Thread Chris Hegarty
On 4 Feb 2013, at 19:36, Ioi Lam ioi@oracle.com wrote: How about adding a message to indicate the sleep, just in case the directory is never created for whatever reason. If you don't like too many such messages, you can print the message after the initial wait. I understand the reason

Re: RFR - 6480539: BigDecimal.stripTrailingZeros() should specify no-op on zero BigDecimals

2013-02-04 Thread Stephen Colebourne
On 4 February 2013 19:31, Joe Darcy joe.da...@oracle.com wrote: The stripTrailingZeros method has acted in this surprising way since the IBM-led JSR 13 was integrated into the platform back in JDK 5, which shipped in 2004. This situation is analogous to when the specification and behavior

hg: jdk8/tl/langtools: 8007490: NPE from DocumentationTool.run

2013-02-04 Thread jonathan . gibbons
Changeset: 1690928dc560 Author:jjg Date: 2013-02-04 15:30 -0800 URL: http://hg.openjdk.java.net/jdk8/tl/langtools/rev/1690928dc560 8007490: NPE from DocumentationTool.run Reviewed-by: darcy ! src/share/classes/com/sun/tools/javadoc/api/JavadocTool.java !

Re: RFR - 6480539: BigDecimal.stripTrailingZeros() should specify no-op on zero BigDecimals

2013-02-04 Thread Joseph Darcy
On 2/4/2013 1:36 PM, Stephen Colebourne wrote: On 4 February 2013 19:31, Joe Darcy joe.da...@oracle.com wrote: The stripTrailingZeros method has acted in this surprising way since the IBM-led JSR 13 was integrated into the platform back in JDK 5, which shipped in 2004. This situation is

hg: jdk8/tl/langtools: 8007492: DocumentationTool cannot locate standard doclet when invoked from JRE

2013-02-04 Thread jonathan . gibbons
Changeset: 62d91c13dce2 Author:jjg Date: 2013-02-04 18:14 -0800 URL: http://hg.openjdk.java.net/jdk8/tl/langtools/rev/62d91c13dce2 8007492: DocumentationTool cannot locate standard doclet when invoked from JRE Reviewed-by: darcy !

Re: RFR: race with nested repos in hgforest.sh

2013-02-04 Thread David Holmes
Chris, When these failures occur does the failure get reflected in an error exit code? I'm seeing hudson builds merilly buildinh OpenJDK instead of Oracle JDK because the closed repos were skipped due to this bug :( David On 2/02/2013 12:40 AM, Chris Hegarty wrote: [ to build-dev and

Re: RFR: race with nested repos in hgforest.sh

2013-02-04 Thread Fredrik Öhrström
Fixing get_source.sh problem: We can hardcode pre-creation of the closed repo locations as mkdir -p calls. We can do the openjdk clone first (in parllell) and when that is finished do the closedjdk clone. We can drop parallell clone altogether because it does not give the speedup we are looking

hg: jdk8/tl: Added tag jdk8-b75 for changeset 2a713921952c

2013-02-04 Thread lana . steuck
Changeset: 5b19cef637a6 Author:katleman Date: 2013-01-31 17:04 -0800 URL: http://hg.openjdk.java.net/jdk8/tl/rev/5b19cef637a6 Added tag jdk8-b75 for changeset 2a713921952c ! .hgtags

hg: jdk8/tl/jaxp: Added tag jdk8-b75 for changeset ff0b73a6b3f6

2013-02-04 Thread lana . steuck
Changeset: 8d65b381880b Author:katleman Date: 2013-01-31 17:04 -0800 URL: http://hg.openjdk.java.net/jdk8/tl/jaxp/rev/8d65b381880b Added tag jdk8-b75 for changeset ff0b73a6b3f6 ! .hgtags

hg: jdk8/tl/corba: Added tag jdk8-b75 for changeset d4e68ce17795

2013-02-04 Thread lana . steuck
Changeset: 4a6be02e66a3 Author:katleman Date: 2013-01-31 17:04 -0800 URL: http://hg.openjdk.java.net/jdk8/tl/corba/rev/4a6be02e66a3 Added tag jdk8-b75 for changeset d4e68ce17795 ! .hgtags

hg: jdk8/tl/hotspot: Added tag jdk8-b75 for changeset 6778d0b16593

2013-02-04 Thread lana . steuck
Changeset: 20b605466ccb Author:katleman Date: 2013-01-31 17:04 -0800 URL: http://hg.openjdk.java.net/jdk8/tl/hotspot/rev/20b605466ccb Added tag jdk8-b75 for changeset 6778d0b16593 ! .hgtags

hg: jdk8/tl/langtools: 2 new changesets

2013-02-04 Thread lana . steuck
Changeset: 716935fec613 Author:katleman Date: 2013-01-31 17:04 -0800 URL: http://hg.openjdk.java.net/jdk8/tl/langtools/rev/716935fec613 Added tag jdk8-b75 for changeset c2e11e2ec4a3 ! .hgtags Changeset: 10619513f51a Author:lana Date: 2013-02-04 22:38 -0800 URL:

hg: jdk8/tl/jdk: 2 new changesets

2013-02-04 Thread lana . steuck
Changeset: 6ba6353ab42c Author:katleman Date: 2013-01-31 17:04 -0800 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/6ba6353ab42c Added tag jdk8-b75 for changeset 4a67fdb752b7 ! .hgtags Changeset: fd37f0846653 Author:lana Date: 2013-02-04 22:37 -0800 URL:

hg: jdk8/tl/jaxws: Added tag jdk8-b75 for changeset 966bf9f3c41a

2013-02-04 Thread lana . steuck
Changeset: a63ef2391c20 Author:katleman Date: 2013-01-31 17:04 -0800 URL: http://hg.openjdk.java.net/jdk8/tl/jaxws/rev/a63ef2391c20 Added tag jdk8-b75 for changeset 966bf9f3c41a ! .hgtags