Re: [PATCH v2] PCI: dwc: Use {upper,lower}_32_bits() macros for clarity

2018-01-02 Thread Lorenzo Pieralisi
On Thu, Dec 28, 2017 at 08:09:55AM -0800, Stephen Boyd wrote: > On 12/28, Joao Pinto wrote: > > > if (pp->ops->get_msi_data) > > > msg.data = pp->ops->get_msi_data(pp, pos); > > > > > > > Thanks for the patch. > > Gustavo' patch-set targeting the update of the Interrupt API for > >

Re: [PATCH v2] PCI: dwc: Use {upper,lower}_32_bits() macros for clarity

2018-01-02 Thread Lorenzo Pieralisi
On Thu, Dec 28, 2017 at 08:09:55AM -0800, Stephen Boyd wrote: > On 12/28, Joao Pinto wrote: > > > if (pp->ops->get_msi_data) > > > msg.data = pp->ops->get_msi_data(pp, pos); > > > > > > > Thanks for the patch. > > Gustavo' patch-set targeting the update of the Interrupt API for > >

Re: [PATCH v2] PCI: dwc: Use {upper,lower}_32_bits() macros for clarity

2017-12-28 Thread Stephen Boyd
On 12/28, Joao Pinto wrote: > > if (pp->ops->get_msi_data) > > msg.data = pp->ops->get_msi_data(pp, pos); > > > > Thanks for the patch. > Gustavo' patch-set targeting the update of the Interrupt API for > pcie-designware* already does this modification, so I would suggest that we

Re: [PATCH v2] PCI: dwc: Use {upper,lower}_32_bits() macros for clarity

2017-12-28 Thread Stephen Boyd
On 12/28, Joao Pinto wrote: > > if (pp->ops->get_msi_data) > > msg.data = pp->ops->get_msi_data(pp, pos); > > > > Thanks for the patch. > Gustavo' patch-set targeting the update of the Interrupt API for > pcie-designware* already does this modification, so I would suggest that we

Re: [PATCH v2] PCI: dwc: Use {upper,lower}_32_bits() macros for clarity

2017-12-28 Thread Joao Pinto
Hi Stephen, Às 11:25 PM de 12/27/2017, Stephen Boyd escreveu: > We have macros for getting the upper or lower 32 bits of a > number. Use them here to shave a couple lines off the code > and provide clarity. > > Signed-off-by: Stephen Boyd > --- > > Changes from v1: > *

Re: [PATCH v2] PCI: dwc: Use {upper,lower}_32_bits() macros for clarity

2017-12-28 Thread Joao Pinto
Hi Stephen, Às 11:25 PM de 12/27/2017, Stephen Boyd escreveu: > We have macros for getting the upper or lower 32 bits of a > number. Use them here to shave a couple lines off the code > and provide clarity. > > Signed-off-by: Stephen Boyd > --- > > Changes from v1: > * Update

[PATCH v2] PCI: dwc: Use {upper,lower}_32_bits() macros for clarity

2017-12-27 Thread Stephen Boyd
We have macros for getting the upper or lower 32 bits of a number. Use them here to shave a couple lines off the code and provide clarity. Signed-off-by: Stephen Boyd --- Changes from v1: * Update dw_msi_setup_msg() too * Reword commit text slightly

[PATCH v2] PCI: dwc: Use {upper,lower}_32_bits() macros for clarity

2017-12-27 Thread Stephen Boyd
We have macros for getting the upper or lower 32 bits of a number. Use them here to shave a couple lines off the code and provide clarity. Signed-off-by: Stephen Boyd --- Changes from v1: * Update dw_msi_setup_msg() too * Reword commit text slightly drivers/pci/dwc/pcie-designware-host.c |