Re: [PATCH 7/8] dmaengine: ste_dma40: Use the BIT macro to replace ugly '(1 << x)'s

2013-04-10 Thread Arnd Bergmann
On Wednesday 10 April 2013, Lee Jones wrote: > On Tue, 09 Apr 2013, Arnd Bergmann wrote: > > Yes, good point. The macro is only used in one place, to compare > > two compile-time constant values, but we should define macros in > > drivers that are already provided by the kernel. > > Okay, it

Re: [PATCH 7/8] dmaengine: ste_dma40: Use the BIT macro to replace ugly '(1 << x)'s

2013-04-10 Thread Lee Jones
On Tue, 09 Apr 2013, Arnd Bergmann wrote: > On Tuesday 09 April 2013, Harvey Harrison wrote: > > > > On Tue, Apr 9, 2013 at 11:39 AM, Lee Jones wrote: > > > > > > The aim is to make the code that little more readable. > > > > > > Signed-off-by: Lee Jones > > > --- > > > > > > > > #define

Re: [PATCH 7/8] dmaengine: ste_dma40: Use the BIT macro to replace ugly '(1 x)'s

2013-04-10 Thread Lee Jones
On Tue, 09 Apr 2013, Arnd Bergmann wrote: On Tuesday 09 April 2013, Harvey Harrison wrote: On Tue, Apr 9, 2013 at 11:39 AM, Lee Jones lee.jo...@linaro.org wrote: The aim is to make the code that little more readable. Signed-off-by: Lee Jones lee.jo...@linaro.org ---

Re: [PATCH 7/8] dmaengine: ste_dma40: Use the BIT macro to replace ugly '(1 x)'s

2013-04-10 Thread Arnd Bergmann
On Wednesday 10 April 2013, Lee Jones wrote: On Tue, 09 Apr 2013, Arnd Bergmann wrote: Yes, good point. The macro is only used in one place, to compare two compile-time constant values, but we should define macros in drivers that are already provided by the kernel. Okay, it looks like

Re: [PATCH 7/8] dmaengine: ste_dma40: Use the BIT macro to replace ugly '(1 << x)'s

2013-04-09 Thread Arnd Bergmann
On Tuesday 09 April 2013, Harvey Harrison wrote: > > On Tue, Apr 9, 2013 at 11:39 AM, Lee Jones wrote: > > > > The aim is to make the code that little more readable. > > > > Signed-off-by: Lee Jones > > --- > > > > > #define MAX(a, b) (((a) < (b)) ? (b) : (a)) > > Not part of your patch, but

Re: [PATCH 7/8] dmaengine: ste_dma40: Use the BIT macro to replace ugly '(1 << x)'s

2013-04-09 Thread Lee Jones
On Tue, 09 Apr 2013, Harvey Harrison wrote: > On Tue, Apr 9, 2013 at 11:39 AM, Lee Jones wrote: > > > > The aim is to make the code that little more readable. > > > > Signed-off-by: Lee Jones > > --- > > > > > #define MAX(a, b) (((a) < (b)) ? (b) : (a)) > > Not part of your patch, but

Re: [PATCH 7/8] dmaengine: ste_dma40: Use the BIT macro to replace ugly '(1 << x)'s

2013-04-09 Thread Harvey Harrison
On Tue, Apr 9, 2013 at 11:39 AM, Lee Jones wrote: > > The aim is to make the code that little more readable. > > Signed-off-by: Lee Jones > --- > > #define MAX(a, b) (((a) < (b)) ? (b) : (a)) Not part of your patch, but probably a good idea to switch to the generic MAX macro, this one is

Re: [PATCH 7/8] dmaengine: ste_dma40: Use the BIT macro to replace ugly '(1 << x)'s

2013-04-09 Thread Arnd Bergmann
On Tuesday 09 April 2013, Lee Jones wrote: > The aim is to make the code that little more readable. > > Signed-off-by: Lee Jones I don't find the new version any more or less readable than the old one, but I have no objections if other people think it's a good idea. Acked-by: Arnd Bergmann --

[PATCH 7/8] dmaengine: ste_dma40: Use the BIT macro to replace ugly '(1 << x)'s

2013-04-09 Thread Lee Jones
The aim is to make the code that little more readable. Signed-off-by: Lee Jones --- drivers/dma/ste_dma40.c | 34 +- 1 file changed, 17 insertions(+), 17 deletions(-) diff --git a/drivers/dma/ste_dma40.c b/drivers/dma/ste_dma40.c index c14db3e..7b96e75 100644

[PATCH 7/8] dmaengine: ste_dma40: Use the BIT macro to replace ugly '(1 x)'s

2013-04-09 Thread Lee Jones
The aim is to make the code that little more readable. Signed-off-by: Lee Jones lee.jo...@linaro.org --- drivers/dma/ste_dma40.c | 34 +- 1 file changed, 17 insertions(+), 17 deletions(-) diff --git a/drivers/dma/ste_dma40.c b/drivers/dma/ste_dma40.c index

Re: [PATCH 7/8] dmaengine: ste_dma40: Use the BIT macro to replace ugly '(1 x)'s

2013-04-09 Thread Arnd Bergmann
On Tuesday 09 April 2013, Lee Jones wrote: The aim is to make the code that little more readable. Signed-off-by: Lee Jones lee.jo...@linaro.org I don't find the new version any more or less readable than the old one, but I have no objections if other people think it's a good idea. Acked-by:

Re: [PATCH 7/8] dmaengine: ste_dma40: Use the BIT macro to replace ugly '(1 x)'s

2013-04-09 Thread Harvey Harrison
On Tue, Apr 9, 2013 at 11:39 AM, Lee Jones lee.jo...@linaro.org wrote: The aim is to make the code that little more readable. Signed-off-by: Lee Jones lee.jo...@linaro.org --- #define MAX(a, b) (((a) (b)) ? (b) : (a)) Not part of your patch, but probably a good idea to switch to the

Re: [PATCH 7/8] dmaengine: ste_dma40: Use the BIT macro to replace ugly '(1 x)'s

2013-04-09 Thread Lee Jones
On Tue, 09 Apr 2013, Harvey Harrison wrote: On Tue, Apr 9, 2013 at 11:39 AM, Lee Jones lee.jo...@linaro.org wrote: The aim is to make the code that little more readable. Signed-off-by: Lee Jones lee.jo...@linaro.org --- #define MAX(a, b) (((a) (b)) ? (b) : (a)) Not part of

Re: [PATCH 7/8] dmaengine: ste_dma40: Use the BIT macro to replace ugly '(1 x)'s

2013-04-09 Thread Arnd Bergmann
On Tuesday 09 April 2013, Harvey Harrison wrote: On Tue, Apr 9, 2013 at 11:39 AM, Lee Jones lee.jo...@linaro.org wrote: The aim is to make the code that little more readable. Signed-off-by: Lee Jones lee.jo...@linaro.org --- #define MAX(a, b) (((a) (b)) ? (b) : (a)) Not