Re: [Python-Dev] Clarification sought about including a multidimensional array object into Python core

2005-02-09 Thread David Ascher
On Wed, 9 Feb 2005 14:45:18 -0800, Guido van Rossum [EMAIL PROTECTED] wrote: The intended user community must accept the code as best-of-breed. It seems that the Num* community has some work to do in this respect. I've not followed the num* discussion in quite a while, but my impression back

Re: [Numpy-discussion] Re: [Python-Dev] Re: Numeric life as I see it

2005-02-09 Thread David Ascher
On Wed, 09 Feb 2005 22:02:11 -0700, Travis Oliphant [EMAIL PROTECTED] wrote: GvR: And why would a Matrix need to inherit from a C-array? Wouldn't it make more sense from an OO POV for the Matrix to *have* a C-array without *being* one? Travis: The only reason I'm thinking of here is to have it

Re: [Python-Dev] Re: [Python-checkins] python/dist/src/Lib xmlrpclib.py, 1.38, 1.39

2005-02-10 Thread David Ascher
On Thu, 10 Feb 2005 15:32:14 -0500, Fred L. Drake, Jr. [EMAIL PROTECTED] wrote: On Thursday 10 February 2005 14:44, Tim Peters wrote: Well, then since that isn't ISO 8601 format, it would be nice to have a comment explaining why it's claiming to be anyway 0.5 wink. I've posted a note on

Re: [Python-Dev] Fixing _PyEval_SliceIndex so that integer-like objects can be used

2005-02-18 Thread David Ascher
On Fri, 18 Feb 2005 13:28:34 -0800, Guido van Rossum [EMAIL PROTECTED] wrote: Would it be possible to change _PyEval_SliceIndex in ceval.c so that rather than throwing an error if the indexing object is not an integer, the code first checks to see if the object has a

Re: [Python-Dev] UserString

2005-02-22 Thread David Ascher
On Tue, 22 Feb 2005 08:16:52 -0800, Guido van Rossum [EMAIL PROTECTED] wrote: Really? I do this kind of thing all the time: import os import errno try: os.makedirs(dn) except OSError, e: if e.errno errno.EEXIST: raise You have a lot more faith in the errno

Re: [Python-Dev] sum()

2005-03-12 Thread David Ascher
You guys have way too much time on your hands and neurons devoted to this stuff. I'm glad that means that I can spend the afternoon playing w/ my kids and searching python-dev when I need to add numbers =). ___ Python-Dev mailing list

Re: [Python-Dev] Re: anonymous blocks

2005-04-27 Thread David Ascher
On 4/27/05, Guido van Rossum [EMAIL PROTECTED] wrote: As long as I am BDFL Python is unlikely to get continuations -- my head explodes each time someone tries to explain them to me. You just need a safety valve installed. It's outpatient surgery, don't worry. --david

Re: [Python-Dev] PEP 340 - possible new name for block-statement

2005-04-29 Thread David Ascher
On 4/28/05, Guido van Rossum [EMAIL PROTECTED] wrote: How about, instead of trying to emphasize how different a block-statement is from a for-loop, we emphasize their similarity? A regular old loop over a sequence or iterable is written as: for VAR in EXPR: BLOCK A

Re: [Python-Dev] PEP 340 - possible new name for block-statement

2005-04-29 Thread David Ascher
On 4/29/05, Guido van Rossum [EMAIL PROTECTED] wrote: [Phillip J. Eby] Although I'd personally prefer a no-keyword approach: synchronized(self): with_file(foo) as f: # etc. I'd like that too, but it was shot down at least once. Maybe we can resurrect it?

Re: [Python-Dev] PEP 340 - possible new name for block-statement

2005-04-29 Thread David Ascher
I agree, but does this then work: x = opening(foo) ...stuff... x as f: # etc ? And if not, why not? And if yes, what happens if stuff raises an exception? Forget it -- the above is probably addressed by the PEP and doesn't really depend on whether there's a kw or not.

Re: [Python-Dev] More tracker demos online

2006-08-04 Thread David Ascher
Martin v. Löwis [EMAIL PROTECTED] wrote in message news:[EMAIL PROTECTED] Currently, we have two running tracker demos online: Roundup: http://efod.se/python-tracker/ Jira: http://jira.python.atlassian.com/secure/Dashboard.jspa Is anyone looking at the Google Code Hosting tracker, just