On Thu, 21 Jun 2001, Jonathan wrote:

> Why is it that each bean (includeing the containing bean) could not have
> BOTH String get/set and also native type get/set?
> 

You can only do this if you use different property names for the same
property.  Otherwise, you'll get compile errors on something like this:

  public Date getStartDate() { ... }
  public String getStartDate() { ... }

or you will violate the naming conventions in the JavaBeans Specification:

  public void setStartDate(Date startDate) { ... }
  public void setStartDate(String startDate) { ... }

and your startDate property will not be recognized by the introspection
logic.

Craig

Reply via email to