On Wed, May 02, 2007 at 03:18:15PM +0300, Vivia Nikolaidou wrote: > On Sun, 29 Apr 2007, Youness Alaoui wrote: > > > Hi, > > can anyone check the use of the traydock ? look at the forum thread > > http://amsn-project.net/forums/viewtopic.php?t=3175 > > it looks like rev 8486 broke the tray dock for many people, it's because > > the diff on that rev was adding a : > > if { [config::getKey dock] == 0 } {return } > > and I'm guessins that some people had the option set to 0 for some reason.. > > Yes, I had this too on my testaccount. No idea what's causing it though. I > manually set it to 1 and I'm having no problems... >
yeah, it was an old variable for sure and it must have been set to 0 for some reason and was kept in your config as 0... > > I just grepped and it looks like that variable is used at some places > > and now I'm thinking maybe it was used for something else... > > Where is it used? I just grepped too (after the grepping I had done when I > readded the option) and got no results... we do have some other > dock-related config values, but not this one... > humm, you're right, I thought I saw more, weird.. anyways, there's a reference to it in the 'amsn' file, that's all I could find (very bad I think since it doesn't care of any profile change!!) > > it could also be that it was used before but wasn't a boolean value, > > like 0 means freedesktop, 1 meant gnomedock, 2 meant windows dock, -1 > > meant disabled... > > Yes, could be... I found this code: > > if {[::config::getKey startontray]} { > if {[::config::getKey dock]!=0} { > wm state . withdrawn > set ishidden 1 > } else { > wm state . iconic > } > } else { > wm state . normal > } > > Does anyone remember where it was used? > well, look here : config.tcl: ::config::setKey dock 1 ;#Docking type config.tcl: ::config::setKey dock 1 config.tcl: #::config::setKey dock 4 ;#Set docking to type 4 (windows) first, it says "docking type", second, it's there twice (you probably added it while it was already there), and finally, although it's commented, you can see that 'dock' was used as the docking type and for windows it was 4, and it was probably other things (we had multiple extensions, we had a gnome1 dock, and we had a freedesktop dock extension (the current libtray), + windows + none.. ) so for sure, the variable was used before and we shouldn't reuse that var because many people probably have the variable set to 0 and hidden in their config, so we should use something like 'enable_tray' or whatever to make sure everyone starts off with the default value 1, and not some other value that was stored long ago.. > > could someone please look into this and see what the variable is used > > for in the other files when you do a grep on it (do a grep on dock, then > > pipe it to a grep on config). If the variable is wrongly chosen, it > > should be renamed like 'enable_tray' or something else that isn't > > already used. > > What do you mean exactly? > > I had performed this search and it seems this variable didn't exist, and I > just tested again now. It was only used in the piece of code I pasted > above. > it did exist.. see above... and btw, the withdraw thing, it should probably not be done that way, it should be in the code handling the dock, because people without 'X11' libraries will not compile libtray, and they launch amsn, so we check 'dock == 1 -> wm state . withdraw' but no tray icon ever appears because libtray is not compiled so people will not see anything, and that's an issue I've seen a few people report in the forums.. we should do the 'start in tray' check inside the code that creates the tray or something and AFTER we made sure it got created successfully... > Viv > Thanks! and here I thought noone read my mail :p welcome back :) KKRT ------------------------------------------------------------------------- This SF.net email is sponsored by DB2 Express Download DB2 Express C - the FREE version of DB2 express and take control of your XML. No limits. Just data. Click to get it now. http://sourceforge.net/powerbar/db2/ _______________________________________________ Amsn-devel mailing list Amsn-devel@lists.sourceforge.net https://lists.sourceforge.net/lists/listinfo/amsn-devel