Hi,

on an Ubuntu 16.04 (no admin rights) with Emacs 24.5 I installed
latest auctex via elpa, but it is the site-lisp one which is seen

Emacs  : GNU Emacs 24.5.1 (x86_64-pc-linux-gnu, GTK+ Version 3.18.9)
 of 2016-04-17 on lgw01-04, modified by Debian
Package: 2014-11-01

current state:
==============
(setq
 AUCTeX-date "2014-11-01"
 window-system 'x
 LaTeX-version "2e"
 TeX-style-path '("/var/lib/auctex/emacs24/" 
"/usr/share/emacs/site-lisp/auctex/style" "/home/userX/.emacs.d/auctex/auto"
                  "/home/userX/.emacs.d/auctex/style" "auto" "style")

In my .emacs file I have 

(cond ((>= emacs-major-version 24)
       (setq custom-file "/home/userX/.emacs.d/custom.el")
       (setq load-path (cons "/home/userX/.emacsaddons" load-path))
       (load-file "/home/userX/.emacs.d/init.el")
       (package-initialize)
       )
      )

and the load-path is 
load-path is a variable defined in `C source code'.
Its value is
("/home/userX/.emacs.d/elpa/auctex-11.89.5/" "/home/userX/.emacsaddons" 
"/usr/share/emacs24/site-lisp/latex-cjk-thai" 
"/usr/share/emacs24/site-lisp/latex-cjk-common" "/etc/emacs24" "/etc/emacs" 
"/usr/local/share/emacs/24.5/site-lisp" "/usr/local/share/emacs/site-lisp" 
"/usr/share/emacs24/site-lisp/dictionaries-common" 
"/usr/share/emacs/site-lisp/autoconf" "/usr/share/emacs24/site-lisp/auctex" 
"/usr/share/emacs/24.5/site-lisp" 
"/usr/share/emacs/24.5/site-lisp/dictionaries-common" 
"/usr/share/emacs/24.5/site-lisp/latex-cjk-common" 
"/usr/share/emacs/24.5/site-lisp/latex-cjk-thai" "/usr/share/emacs/site-lisp" 
"/usr/share/emacs/24.5/lisp" "/usr/share/emacs/24.5/lisp/vc" 
"/usr/share/emacs/24.5/lisp/url" "/usr/share/emacs/24.5/lisp/textmodes" 
"/usr/share/emacs/24.5/lisp/progmodes" "/usr/share/emacs/24.5/lisp/play" 
"/usr/share/emacs/24.5/lisp/org" "/usr/share/emacs/24.5/lisp/nxml" 
"/usr/share/emacs/24.5/lisp/net" "/usr/share/emacs/24.5/lisp/mh-e" 
"/usr/share/emacs/24.5/lisp/mail" "/usr/share
 /emacs/24.5/lisp/leim" "/usr/share/emacs/24.5/lisp/language" 
"/usr/share/emacs/24.5/lisp/international" "/usr/share/emacs/24.5/lisp/gnus" 
"/usr/share/emacs/24.5/lisp/eshell" "/usr/share/emacs/24.5/lisp/erc" 
"/usr/share/emacs/24.5/lisp/emulation" "/usr/share/emacs/24.5/lisp/emacs-lisp" 
"/usr/share/emacs/24.5/lisp/cedet" "/usr/share/emacs/24.5/lisp/calendar" 
"/usr/share/emacs/24.5/lisp/calc" "/usr/share/emacs/24.5/lisp/obsolete" 
"/usr/share/emacs/site-lisp/auctex")

When I do list-packages the 11.89.5 is reported as correctly installed.

is there some other path variable to customize in order for locally elpa 
installed AucTeX to be the one picked up ?

before the system upgrade to Ubuntu 16.04 I did not have that issue; I was then 
using a self-compiled Emacs 24.5 as the system the provided only Emacs 23; 
after the system upgrade I removed my local /bin etc... from PATH and started 
using the system-wide Emacs as it was already the 24.5 one; I did not however 
test AUCTeX 11.89.3/4 in this new configuration as I immediately upgraded to 
11.89.5)

Jean-Francois







"/usr/share/emacs/site-lisp/auctex")
_______________________________________________
auctex mailing list
auctex@gnu.org
https://lists.gnu.org/mailman/listinfo/auctex

Reply via email to