I tried asking on #bcm-users, then found the wiki where it's suggested
to report to this list, so I'm doing so. Sorry for the noise on IRC.

A description of the problem at hand:

My card works fine when I use it with WPA, however when I try to use it
without any encryption (actually the provider uses MAC-based filtering,
but that's not important), then after the "iwconfig eth0 essid <essid>",
"iwconfig" shows the MAC of the AP, and after about 5 secs "iwconfig"
says it's "Not-Associated". If I run iwconfig eth0 essid again, then
it's usable again for ~5 secs and so on. When the AP goes unassociated,
I see this in dmesg:

No probe response from AP 00:12:17:d3:87:f5 after 500ms, disconnecting.

When it happens:

It happens only in case not using encryption. An other laptop with
ipw2200 driver works fine, so I guess this will be a b43 or firmware
problem. The same card works under Windows XP as well, so I guess it's
not a hardware problem.

How to reproduce:

Run "iwconfig eth0 essid <essid>", wait ~5 secs and run "iwconfig"
again. Result: it's unassociated. Expected: to show the MAC of the AP,

$ uname -a
Linux s12 2.6.32-fw2 #1 SMP PREEMPT Sat Dec 19 13:56:14 CET 2009 x86_64

$ sudo lspci -vvn|grep 43 -A7
00:00.4 0600: 1106:4353
        Subsystem: 17aa:3889
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping- SERR- FastB2B- DisINTx-
        Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- 
<TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 32 bytes

00:00.5 0800: 1106:5353 (prog-if 20 [IO(X)-APIC])
        Subsystem: 17aa:388a
02:00.0 0280: 14e4:4315 (rev 01)
        Subsystem: 14e4:04b5
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- 
<MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 32 bytes
        Interrupt: pin A routed to IRQ 28
        Region 0: Memory at f5200000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 3
        Kernel driver in use: b43-pci-bridge
        Kernel modules: ssb

dmesg: http://frugalware.org/~vmiklos/files/dmesg-s12

Wlan configuration, authentication/encryption type:

b43 from vanilla kernel, no encryption. Firmware is installed as
described at http://linuxwireless.org/en/users/Drivers/b43#fw-b43-lp

kernel is a distro-packaged vanilla

Any ideas?


Attachment: pgpkGdUyIEjyK.pgp
Description: PGP signature

Bcm43xx-dev mailing list

Reply via email to