I have same problems with SPI1. Guilty part seems to be wl18x that requires 
pulldown on certain pin. See /opt/source/dtb-4.4-ti/src/arm/
 (included by am335x-bonegreen-wireless.dts). Last fragment introduces 
gpio-hog of pin p9.30.  I've tried to enable SPIDEV1 on boot which leads to 
wilink crashing on init. 
Comment on file shows that it is somehow related to BT_AUD which I dont 
need but I need wlan and bluetooth. I dont know if that is hardwired or not 
but changing that hog-pin to another was NOT good idea... 

So I need to re-route my wirings to SPI0 (which overlaps my I2C-2...) so 
i'll be quite busy for a while...

Please inform here if solution is found. 

perjantai 23. kesäkuuta 2017 18.33.16 UTC+3 mjbo...@gmail.com kirjoitti:
> Problem "solved" (worked around really) by switching to SPI0, changing the 
> pins around and rerouting most of our custom cape.
> There are still some problems with the SPI bus but that's a separate issue.

For more options, visit http://beagleboard.org/discuss
You received this message because you are subscribed to the Google Groups 
"BeagleBoard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to beagleboard+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
For more options, visit https://groups.google.com/d/optout.

Reply via email to