Pierre Labastie wrote:
On 22/02/2018 06:05, Bruce Dubbs wrote:
Ken Moffat wrote:
On Thu, Feb 22, 2018 at 01:18:02AM +0000, Ken Moffat wrote:
On Wed, Feb 21, 2018 at 06:04:54PM -0600, Bruce Dubbs wrote:
I tried to build gpgme with gnupg and just couldn't make it work.  I tried
using --disable-gpg-test and several other --disable options, but it kept
failing during the make phase because gnupg programs were not present.

I gave up and installed gnupg and then everything was OK.

I recommend making gnupg required for gpgme but will wait for feedback.

    -- Bruce
See the thread on blfs-support.  Spiky reported the problem, and
eventually built gnupg.  Pierre noted the test programs are always
built and offered a --disable suggestion.

I don't have any use for gpgme, so I've not tried to build it.
And all cores of my current machine are in use, so I can't try
building it at the moment.

Pierre fixed it in r19805!

My build completed, so I built it (without gnupg) and now confirm that
it built for me using --disable-gpg-test.

Hmm.  I use a script that does:

./configure --prefix=/usr --disable-gpg-test

In the log is:

Making all in tests
gpgconf --kill all
echo "ignore-invalid-option allow-loopback-pinentry" >
echo "allow-loopback-pinentry" >> gpg-agent.conf
echo "ignore-invalid-option pinentry-mode" > gpg.conf
echo "pinentry-mode loopback" >> gpg.conf
gpg --no-permission-warning \
            --import ../../../tests/gpg/pubdemo.asc

Without gpg, this last line causes make to stop with an error.

I tried the above with --disable-gpgconf-test --disable-gpgsm-test
--disable-g13-test and it still failed for me at the same place.

Investigating, it appears that the above is in lang/qt/tests/Makefile and is
not disabled with any of the configure options.

Note that I have Qt5 and pinentry installed.  It seems that with some sets of
dependencies that gpg is required.

Investigating, it appears that the above is in lang/qt/tests/Makefile and is
not disabled with any of the configure options.

I suppose I can avoid it with:

sed -i '/^SUBDIRS/s/tests//' lang/qt/Makefile.in

but do we want to do that?  "If no gnupg but have qt then ..."

Note: Tested with the sed (and --disable-gpg-test) and there is no ^gpg in the

   -- Bruce

I guess if swig is installed, the tests in python directory will be built, and
generate an error too, so another sed would be needed.

We could use --disable-languages, document that it would remove any bindings,
document which languages can be enabled, and instruct users that gnupg must be
installed to build qt or python bindings.
Or restrict to --enable-languages="cl cpp", which do not bring deps (with the
same documentation as above)
Or recommend gnupg, but not "require" it, since it can be disabled.

Also report upstream that the construct in top Makefile.am for subdir tests,
should be transposed to lang/{python,qt}/Makefile.am.

For now, I am adding a parenthetical comment:

<xref linkend="gnupg2"/> (required if Qt or SWIG are installed;
used during the testsuite),

  -- Bruce

FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Reply via email to