I am trying to rescue data from a damaged external HDD (WD Elements
   3TB). It is a MacOS disk, and I am using ddrescue v1.27 on Linux.

   I used the same command switches as I did in my previous ddrescue
   sessions, but this time the session went slower and slower, running for

   I decided to wait patiently and here is how the display looks now:


   # ddrescue -f -r 3 /dev/sdc kata-wd.dd map.txt
   GNU ddrescue 1.27
   Press Ctrl-C to interrupt
   Initial status (read from mapfile)
   rescued: 2321 GB, tried: 172142 kB, bad-sector: 0 B, bad areas: 0

   Current status
        ipos:    1893 GB, non-trimmed:  735621 kB,  current rate:       0
        opos:    1893 GB, non-scraped:        0 B,  average rate:       0
   non-tried:  677953 MB,  bad-sector:        0 B,    error rate:     181
     rescued:    2321 GB,   bad areas:        0,        run time: 39d 11h
   pct rescued:   77.38%, read errors:     8598,  remaining time:
                                 time since last successful read:
   Copying non-tried blocks... Pass 5 (forwards)


   The "non-tried" value decreases and "non-trimmed" increases slowly by
   same amount, at speed of approximately 20-40Mb per day.

   I am asking for recommendation what to do.

   Should I interrupt the process? If so, what to do next? The image file
   is smaller than the original disk, how can I repair it? Should I try
   Mac first aid command, or fsck maybe?

   Or, should I restart the process with a different combination of
   command switches?

   Please help.

   Best regards,


Reply via email to