Paul Smith wrote:
> I had a Solaris11 OVA and I ran the pkg
> install developer/gcc-11 and it did lots of things but afterward there
> was no gcc program installed (I searched the entire disk for "*gcc*").
> Weird.

On Solaris 11 from Oracle, "pkg search /usr/bin/gcc" and
"pkg search /usr/bin/g++" told me that what I need is package
'developer/gcc/gcc-c++', so there I did
  sudo pkg install developer/gcc/gcc-c++

> So then I installed OpenIndiana based on your notes and that succeeded
> and I was able to build make and run the tests.
> Unfortunately I wasn't able to reproduce the problem; all tests passed
> for me (I'm using a build where the ar issue is already fixed).  I
> tried with 1 CPU as well just to be sure.
> Sigh!
> I wonder what can be different about what I'm doing and what you're
> doing.

At this point I am out of clues too. Maybe it's related to the speed
of the CPU (e.g. execution speed vs. context switch speed ratio)?

> Maybe it's related to how the tests are run; I suppose you're
> using some sort of automated testing framework?  Maybe there's no TTY
> or something?  Can you briefly describe how the tests are invoked?

In a session with a TTY (GUI terminal in OpenIndiana, plain console in
Solaris 11.4), I run a /bin/sh script that contains these lines:

test -f configure || { echo "This script must be invoked from a configurable 
package." 1>&2; exit 1; }
rm -rf build-64-gcc
mkdir build-64-gcc
cd build-64-gcc
$HOME/configure-64-gcc "$@" 2>&1 | tee log1 \
&& gmake 2>&1 | tee log2 \
&& gmake check 2>&1 | tee log3

Sometimes I also do "gmake check" without the redirection; there's
normally no difference between with and without redirection.


Reply via email to