Just a thought...

When you went from 5.1.4 to 5.2.0, did you update the Maven overlay
template from GitHub and then re-apply your local changes, or did you just
update ${cas.version}?

In my (limited) experience, just updating the version doesn't always work,
and it's better to update from the repo every time a new version comes out.

--Dave



--

DAVID A. CURRY, CISSP
*DIRECTOR OF INFORMATION SECURITY*
INFORMATION TECHNOLOGY

71 FIFTH AVE., 9TH FL., NEW YORK, NY 10003
+1 212 229-5300 x4728 • david.cu...@newschool.edu

[image: The New School]

On Tue, Dec 12, 2017 at 11:17 AM, crdaudt <crda...@taylor.edu> wrote:

> Just a quick addendum:  I tried deleting the repositories in my .m2
> directory prior to performing a maven build in order to make sure that
> preexisting repos were not the cause of my issue.  I am still having the
> same issue.
> Thanks in advance to anyone who can assist with some ideas.
>
> On Friday, December 8, 2017 at 1:37:31 PM UTC-5, crdaudt wrote:
>>
>> I am attempting to update from CAS 5.1.4 to 5.2.0 in our test
>> environment, but am having dependency issues.  The maven build works
>> without errors, but I receive the following WARN message in cas.log when I
>> deploy and start tomcat:
>>
>> 2017-12-08 08:54:56,387 WARN [org.springframework.boot.cont
>> ext.embedded.AnnotationConfigEmbeddedWebApplicationContext] - <Exception
>> encountered during context initialization - cancelling refresh attempt:
>> org.springframework.beans.factory.UnsatisfiedDependencyException: Error
>> creating bean with name 'casReportsConfiguration': Unsatisfied dependency
>> expressed through field 'authenticationSystemSupport'; nested exception is
>> org.springframework.beans.factory.UnsatisfiedDependencyException: Error
>> creating bean with name 'defaultAuthenticationSystemSupport' defined in
>> class path resource [org/apereo/cas/config/CasCore
>> AuthenticationSupportConfiguration.class]: Unsatisfied dependency
>> expressed through method 'defaultAuthenticationSystemSupport' parameter
>> 1; nested exception is org.springframework.beans.fact
>> ory.UnsatisfiedDependencyException: Error creating bean with name
>> 'authenticationTransactionManager' defined in class path resource
>> [org/apereo/cas/config/CasCoreAuthenticationConfiguration.class]:
>> Unsatisfied dependency expressed through method
>> 'authenticationTransactionManager' parameter 0; nested exception is
>> org.springframework.beans.factory.UnsatisfiedDependencyException: Error
>> creating bean with name 'casAuthenticationManager' defined in class path
>> resource [org/apereo/cas/config/CasCoreAuthenticationConfiguration.class]:
>> Unsatisfied dependency expressed through method 'casAuthenticationManager'
>> parameter 2; nested exception is 
>> org.springframework.beans.factory.BeanCreationException:
>> Error creating bean with name 'authenticationEventExecutionPlan' defined
>> in class path resource [org/apereo/cas/config/CasCore
>> AuthenticationConfiguration.class]: Bean instantiation via factory
>> method failed; nested exception is 
>> org.springframework.beans.BeanInstantiationException:
>> Failed to instantiate [org.apereo.cas.authentication
>> .AuthenticationEventExecutionPlan]: Factory method
>> 'authenticationEventExecutionPlan' threw exception; nested exception is
>> org.springframework.beans.factory.BeanCreationException: Error creating
>> bean with name 'ldapAuthenticationHandlers' defined in class path resource
>> [org/apereo/cas/config/LdapAuthenticationConfiguration.class]: Bean
>> instantiation via factory method failed; nested exception is
>> org.springframework.beans.BeanInstantiationException: Failed to
>> instantiate [java.util.Collection]: Factory method
>> 'ldapAuthenticationHandlers' threw exception; nested exception is
>> java.lang.NoSuchMethodError: org.ldaptive.ConnectionConfig.
>> setConnectTimeout(Ljava/time/Duration;)V>
>>
>> Then I receive an ERROR message that my Application startup failed.
>>
>> I did not have these WARN and ERROR messages with v5.1.4.  I am not sure
>> how to track this down.
>>
>> Attached are the first 82 lines of my cas.log file, my pom.xml file for
>> CAS 5.2.0, and my working pom.xml file used to build CAS 5.1.4.
>>
>> Any ideas?
>>
>>
>> --
> - Website: https://apereo.github.io/cas
> - Gitter Chatroom: https://gitter.im/apereo/cas
> - List Guidelines: https://goo.gl/1VRrw7
> - Contributions: https://goo.gl/mh7qDG
> ---
> You received this message because you are subscribed to the Google Groups
> "CAS Community" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to cas-user+unsubscr...@apereo.org.
> To view this discussion on the web visit https://groups.google.com/a/
> apereo.org/d/msgid/cas-user/bbbd7035-fa1b-4829-9ceb-
> 84a8394d710f%40apereo.org
> <https://groups.google.com/a/apereo.org/d/msgid/cas-user/bbbd7035-fa1b-4829-9ceb-84a8394d710f%40apereo.org?utm_medium=email&utm_source=footer>
> .
>

-- 
- Website: https://apereo.github.io/cas
- Gitter Chatroom: https://gitter.im/apereo/cas
- List Guidelines: https://goo.gl/1VRrw7
- Contributions: https://goo.gl/mh7qDG
--- 
You received this message because you are subscribed to the Google Groups "CAS 
Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to cas-user+unsubscr...@apereo.org.
To view this discussion on the web visit 
https://groups.google.com/a/apereo.org/d/msgid/cas-user/CA%2Bd9XAMK7yjUhEGLEpT84wyYk8sQZY0jctf0Zhn86znqgdQykQ%40mail.gmail.com.

Reply via email to