I have big trouble to start the idmap service by SMF.

The service runs normal over several days, but after a reboot of the system the 
service went into
maintenance mode.

The log says, that the daemon can't create the database /var/idmap/idmap.db.

Well, when i search for this error, i found older threads from 2008 about this 
behavior, and
they commend to disable the service, remove /var/idmap/idmap.db and 
and restart the idmap service.

But, that change nothing on my system.

When I run the idmapd manually with '/usr/lib/idmapd -d', the service runs 
Only when I try to start the service with SMF, then it fails.

This is the output from /var/svc/log/system-idmap\:default.log:

[ Mar 26 15:40:54 Enabled. ]
[ Mar 26 15:40:54 Executing start method ("/usr/lib/idmapd"). ]
debug/config = 1
debug/discovery = 1
Loading configuration.
change machine_sid=S-1-5-21-1616384715-857007953-2666771857
change unresolvable_sid_mapping=true
change use_lsa=true
change disable_cross_forest_trusts=true
change directory_based_mapping=name
change ad_unixuser_attr=unixUserName
change ad_unixgroup_attr=unixGroupName
change default_domain=contact.de
change domain_name=contact.de
Configuration changed
Initial configuration loadedLoading configuration.
Running discovery.
Error creating database /var/idmap/idmap.db (malformed database schema - unable 
to open
a temporary database file for storing temporary tables)
Failed to initialize db /var/idmap/idmap.db
unable to initialize mapping system
[ Mar 26 15:40:54 Method "start" exited with status 1. ]

When i look at the manually configured settings of the daemon, I can't see any 
eye-catching setting, that prevent the service to start.

svcprop -c -p config idmap

config/list_size_limit count 0
config/stability astring Unstable
config/value_authorization astring solaris.smf.value.idmap
config/ad_unixgroup_attr astring unixGroupName
config/ad_unixuser_attr astring unixUserName
config/machine_sid astring S-1-5-21-1616384715-857007953-2666771857
config/domain_name astring contact.de
config/directory_based_mapping astring name
config/default_domain astring contact.de

As I say before, when i run the service manually, it starts perfectly, and 
wrote nothing about 
malformed database schema to the output.

By now i have no ideas to motivate the idmap to run normally by SMF.

Do you have any ideas, why the daemon can't create the idmap Databases?

Thanks and regards,
Marc Steinlein

cifs-discuss mailing list

Reply via email to